
The Advanced Guide to
Microsoft Excel 2010
Microsoft Office Specialist Exam 77-888 Study Guide

Microsoft Excel 2010 Advanced



. Advanced Guide to Microsoft Excel 2010
© 2011 Comma Productions 
9090 Chilson Road
Brighton, MI 48116
978-0-9838917-5-8

Trademark and Copyright
Microsoft Word ® , Microsoft Excel ®, Microsoft Access ®, Microsoft Outlook ®, Microsoft PowerPoint 
®, Microsoft Windows ® are trademarks or registered trademark of Microsoft Corporation. Adobe 
Photoshop® and Acrobat® are trademarks or register trademarks of Adobe Corporation. 

Limit of Liability/Disclaimer of Warranty: 
The Publisher and Author make no representation or warranties with respect to the accuracy or 
completeness of the contents of this work and specifically disclaim all warranties including without 
limitations warranties of fitness for a particular purpose. The advice and strategies contained herein 
may not be suitable for every situation. The fact that an organization is refereed to in this work as a 
citation and/or potential source of further information does not mean that the authors or publisher 
endorses the information that the organization or website may provide or recommendations it may 
make. Readers should be aware that Internet websites listed in this work may have changed or 
disappeared between when this work was written and when it is read.

Neither Comma Productions nor Author shall be liable for any loss of profit or any other commercial 
damages including but not limited to special, incidental, consequential or other damages.

Comma Training Page 2



Advanced Guide to Microsoft Excel 2010
Chapter 1: Tables and List
Take 1: Works for Me!, page 11
Objectives and Menu Map, page 12
Practice, page 45
Test Yourself, page 46

Take 2: Work Smarter, Not Harder, page 47
Objectives and Menu Map, page 48
Practice, page 81
Test Yourself, page 82

Chapter 2: Analyzing Data Visually
Take 1: What Happened? (Pivot Tables), page 83
Objectives and Menu Map, page 84
Practice, page 117
Test Yourself, page 118

Take 2: What Did You See? (Pivot Charts), page 119
Objectives and Menu Map, page 120
Practice, page 159
Test Yourself, page 160

Chapter 3: Sharing and Collaboration
Take 1: Working Overtime, page 161 
Objectives and Menu Map, page 162
Practice, page 194
Test Yourself, page 194

Take 2: Prepare to Share, page 195 
Objectives and Menu Map, page 196
No Practice Activity
Test Yourself, page 244

Take 3: Working with Macros, page 245 
Objectives and Menu Map, page 246
Practice, page 293
Test Yourself, page 294

Advanced Excel Skill Test, page 295

Microsoft Excel 2010 Study Guide, page 7
Index, page 297

Comma Training Page 3

Advanced Excel 2010 Page 3 of 298



What is the Microsoft Office Specialist Certification Program?
The Microsoft Office Specialist (MOS) Certification Program enables candidates to show that they have something 
exceptional to offer – proven expertise in Microsoft Office programs. Recognized by businesses and schools around the 
world, millions of certifications have been obtained in over 100 different countries. The Microsoft Office Specialist 
(MOS) Certification Program is the only Microsoft-approved certification program of its kind.

The Microsoft Office Specialist Certification Series
Core Certification: Pass any 1 test:
Word 2010 Core: Exam 77-881
Excel® 2010 Core: Exam 77-882
PowerPoint® 2010: Exam 77-883
Access® 2010: Exam 77-885
Outlook® 2010: Exam 77-884

Expert Certification: Pass either test:
Word 2010 Expert: Exam 77-887
Excel® 2010 Expert: Exam 77-888

Master: Pass 3 required and 1 elective test:
Required
Word 2010 Expert: Exam 77-887
Excel® 2010 Expert: Exam 77-888
PowerPoint® 2010: Exam 77-883

Elective
Access® 2010: Exam 77-885 or 
Outlook® 2010: Exam 77-884

Please Note: Comma Productions, LLC. is independent from Microsoft Corporation, and not affiliated with Microsoft in any manner. While the Complete 
Computer Guides may be used in assisting individuals to prepare for a Microsoft Office Specialist Certification exam, Microsoft, its designated program 
administrator, and Comma Productions, LLC. do not warrant that use of these Complete Computer Guides will ensure passing a Microsoft Office Specialist 
Certification exam.

Microsoft Office Specialist Certification

What is the Microsoft Office 
Specialist Certification? 

The Microsoft Office Specialist certification 
validates through the use of exams that 
you have obtained specific skill sets within 
the applicable Microsoft Office programs 
and other Microsoft programs included in 
the Microsoft Office Specialist Program. 
The candidate can choose which exam(s) 
they want to take according to which skills 
they want to validate. 

CertiPort  is the premier provider for 
validating technology skills. 

The Microsoft Office Specialist tests are 
offered at authorized testing centers.

For more information on the MOS exam 
topics or to find a testing center near you 
please contact: www.certiport.com
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The Benefits of Certification
Why Get Certified?
For employers, the certification provides skill-verification tools that not only help assess a person's skills in using 
Microsoft Office programs but also the ability to quickly complete on-the-job tasks across multiple programs in the 
Microsoft Office system. (http://www.microsoft.com/learning/en/us/certification/mos.aspx).  Certification proves a certain 
level of advanced competency with the programs in question.  Employers don’t have to wonder if the skills stated on the 
resume are honest and without exaggeration.  This can lead to further employment opportunities and increased pay.  

A person holding Microsoft Office Certification shows not just a level of skill, but an ability to quickly complete tasks, due 
to familiarity with the program and it’s many time-saving features.  The hard work that goes into learning Microsoft Office 
programs to the level of proficiency necessary for successful completion of the Certification Exams also indicates a 
desire on behalf of the student to learn and succeed.   

The Benefits: Earn More, Find Jobs Quicker
Research indicates that employees with Microsoft Certification earn more and find jobs quicker than those employees 
without certification.  Furthermore, employees with certification report a greater feeling of confidence.  These things 
translate into greater job satisfaction.  (http://www.microsoft.com/learning/en/us/certification/mos.aspx)

Research also shows that individuals with certification make up to 12% more than those without certification.  In addition, 
82% of Microsoft Office Specialists report a salary increase after receiving certification.  Managers like the skills proven 
and the ability demonstrated by those with Microsoft Office Certifications.  
http://www.certiport.com/Portal/desktopdefault.aspx?page=common/pagelibrary/mos2003.html

For More Information:
www.certiport.com
www.microsoft.com
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About Our Certification Program
Microsoft Office Specialist (MOS) Certification for Excel 2010
Overview: Our Microsoft Office Specialist certification program for Word 2010 has three levels of mastery: Beginning, 
Intermediate and Advanced. In general, the CORE exam topics are demonstrated in the Beginning and Intermediate 
Guides. EXPERT concepts are included where relevant, with the Advanced Guide only covering EXPERT concepts

Our Approach: In designing these Guides, we found that it made more sense to write the lessons based on the Ribbons 
and Tasks. For example, the Beginning Guide to Microsoft Excel 2010 shows all of the Picture Tools: CORE and 
EXPERT. The beginning of each lesson provides an overview of the Ribbons and Tasks covered.

The Beginning Guide to Microsoft Excel 2010 demonstrates the following Ribbons: Home, Formula, Insert, Picture 
Tools, Drawing Tool, SmartArt Tools: Design, Chart Tools, Chart Tools: Layout: Labels The lesson activities focus 
on basic data and formula entry as well as inserting and formatting graphics and charts.

The Intermediate Guide to Microsoft Excel 2010 demonstrates the following Ribbons: Formulas, Page Layout,
Insert, Sparkline Tools. The lesson activities focus on additional formulas as well as page options, finishing with the 
use of Sparklines.

The Advanced Guide to Microsoft Excel 2010 demonstrates the following Ribbons: Table Tools, Table Tools, Data, 
PivotTable Tools: Design, PivotTable Tools: Options, PivotChart Tools: Design, PivotChart Tools: Analyze, 
Review, Developer. The lesson activities further explore presentation with advanced Table options as well as 

PivotCharts and PivotTables, finishing with sharing and form controls.

Course Prerequisites: Students who enroll in Microsoft Office Specialist (MOS) program should have basic computer 
skills including how to turn on the computer, how to use an Internet browser and how to select commands from a menu. 
Students should know how to save files and send attachments by email as well.

Books in this Series:
Beginning Guide to 
Microsoft® Excel 2010

Intermediate Guide to 
Microsoft® Excel 2010

Advanced Guide to 
Microsoft® Excel 2010
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Microsoft Excel 2010 Study Guide: Advanced Excel
             Microsoft Office Specialist (MOS): Exam 77-882 and 77-888 for Excel 2010

From the Excel 2010 CORE Exam 77-882
1. Managing the Worksheet Environment 
1.1. Navigate Through a Worksheet 
Keyboard: Hot keys, Pg 283

1.3. Personalize the Excel Environment by 
Using the Backstage 
Quick Access: Add a Command, Pg 220
Backstage: Ribbons, Tabs, Groups, Pg 184
Data: Import Data to Excel, Pg 276
Data: Export Data From Excel, Pg 290
Backstage: Workbook Properties, Pg 223
Backstage: Save, Save As, Pg 71

2. Creating Cell Data
2.2. Apply AutoFill
Format Same as Above or Below, Pg 252

From the Excel 2010 CORE Exam 77-882
7.2. Manage Comments 
Review: Add New Comment, Pg 215
Review: Show/Hide Comment, Pg 217
Review: Edit Comment, Pg 216
Review: Delete Comment, Pg 217

8. Analyzing and Organizing Data
8.1. Filter Data
Data Filter: Define, Pg 52
Data Filter: Apply, Pg 54
Data Filter: Clear, Pg 55
Data Filter: Search, Pg 53
Data: AutoFilter, Pg 53

8.2. Sort Data
Data: Sort Options, Pg 51

8.3. Apply Conditional Formatting
Conditional Formatting: Apply Conditional 
Formatting, Pg 31
Conditional Formatting: Rules Manager, Pg 38
Conditional Formatting: Apply Conditional 
Formatting Based on Logical Formula, Pg 31
Conditional Formatting: Icon Sets, Pg 37
Conditional Formatting: Data Bars, Pg 35
Conditional Formatting: Clear the Rules, Pg 34

From the Excel 2010 EXPERT Exam 77-888
1. Sharing and Maintaining Workbooks
Backstage: Advanced Properties, Pg 223
Data: Import and Export XML, Pg 276
Review: Protect Sheet, Pg 206
Review: Protect Workbook, Pg 207
Backstage: Protect Workbook, Pg 229
Backstage: Encrypt with a Password, Pg 232
Compare and Merge Workbooks, Pg 219
Review: Track Changes, Pg 211

Keep going. There's more...
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Microsoft Excel 2010 Study Guide: Advanced Excel
             Microsoft Office Specialist (MOS): Exam 77-882 and 77-888 for Excel 2010

From the Excel 2010 EXPERT Exam 77-888
2. Applying Formulas and Functions 
Analyze Data: Slicers, Pg 150

3. Presenting Data Visually
3.1. Apply Advanced Chart Features
PivotTable: Edit Field Values, Pg 94
PivotTable: Analyze with Slicers, Pg 149
PivotChart: Create a PivotChart, Pg 124
PivotChart: Filter the Data, Pg 134
PivotChart: Analyze the Data, Pg 142
PivotTables: Slicer Tools, Pg 152

From the Excel 2010 EXPERT Exam 77-888
4. Working with Macros and Forms
Macros: Run a Macro, Pg 260
Macros: Run a Macro On Open, Pg 284
Macros: Click a Button to Run, Pg 261
Macros: Record an Action Macro, Pg 251
Macro: Assign a Macro to a Command Button, Pg 266
Macro: Add a Macro to the Quick Access Toolbar, Pg 268
Macro: Modify the Macro, Pg 256
Developer: Add Form Controls, Pg 186
Developer: Edit Form Controls, Pg 189
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About the Authors
             Microsoft Office Specialist (MOS): Exam 77-888 for Excel 2010
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 How To Use This Guide
            Microsoft Office Specialist Certification Training

The Comma Method
Observation is a perceptual strategy that asks: why am I doing this 
and which tools would be most effective? Each lesson begins with 
a discussion of the purpose and the objectives.

Orientation helps students start at the right place. The screen 
shots in the Complete Compute Guides show the entire window as 
well as a close up of the particular button or command. 

Notation There are "breadcrumbs" above each screen image. Like 
Hansel and Gretel, the breadcrumbs show the pathway to a button 
or option. Our notation uses the following convention:
Ribbon->Group->Button->Options

Menu Maps
The Comma Method recognizes that there is a difference in how 
men and women navigate the menus. Men typically have the ability 
to see the map first. This method of acquiring knowledge is called 
Breadth-first. [1] Women tend to work with the details first. They 
learn several commands, such as copy, cut, and paste, then they 
put those concepts under the label, “edit.” This method of learning 
is called Depth-first. 

The Comma Method uses menu mapping to assist men and 
women to see both the Breadth and the Depth. An example of the 
menu map is can be seen here.

[1] Ford, Nigel, Sherry Chen, Matching/mismatching revisited: An Empirical Study of 
Learning and Teaching Styles. British Journal of Educational Technology v.32 no1 
(Jan. 2001)

Data-> Data Tools
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© 2011 Comma Productions, LLC

Advanced Excel: Organizing Data

Advanced Excel Objectives
In this lesson, you will learn how to: 
1. Create a Table
2. Identify the Header Row with the Table Tools
3. Locate the Quick Style Formats
4. Use the Table Tools to add a Total Row
5. Convert Tables to Text
6. Convert Text to Tables

It Works for Me
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Table Tools

Table Tools
1. Readings
Read Lesson 1 in the Advanced Excel 
guide, page 11-44.

Project
A spreadsheet that works with Tables in Excel. 
This lesson shows how to present data visually, 
format data as a Table and calculate the Totals.

Downloads
Sales Data 2010.xls
Student Records.xlsx

2. Practice
Complete the Practice Activity on page 45.

3. Assessment
Review the Test questions on page 46.

Menu Maps
This lesson demonstrates options on the Table Tools Ribbon.
1. Table Tools->Design ->Table Styles, page 24
2. Table Tools->Design ->Table Style Options->Header Row, page 25
3. Table Tools->Design ->Table Style Options -> Total Row, page 27
4. Table Tools-> Design ->Table Styles -> Clear, page 30
5. Table Tools-> Design ->Properties-> Resize Table, page 41
6. Table Tools-> Design ->Tools-> Remove Duplicates, page 42
7. Table Tools-> Design ->Tools-> Convert to Range, page 44

From the Home Ribbon
Home -> Conditional Formatting, page 31

Lesson 1: It Works for Me
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Start Microsoft Excel
What Do You See? Is 
there a blue Title Bar that 
says Microsoft Excel? Yes.

Is there a Home Ribbon 
with the Clipboard, Font, 
Alignment and Number 
Groups? Yes.

If your screen looks similar 
to the example on this 
page, then you are ready 
to get started.

Start -> All Programs ->Microsoft Office-> Microsoft Office Excel 2010

Organizing Data with Tables
One of the unique functions of a computer is to organize information into Rows and Columns. Microsoft Excel 
does Rows and Columns: specifically Tables. Tables can be little reference lists that are named and used in a 
formula. One good example is a Lookup table. By definition, vLookup has the data in Columns (vertical). 
Hlookup has the data in Rows (horizontal).  The Advanced Guide to Excel begins with Tables and Table Tools.
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File -> Open

Before You Begin
The purpose of this lesson is to investigate 
the Table Options in Microsoft Excel 2010. 
You can use a spreadsheet that you created 
or download a sample spreadsheet if you 
wish.

1. Try This: Open a Sample Spreadsheet
Open a sample spreadsheet: Sales2010.xlsx
Go to the Original Data sheet.

2. What Do You See? This sheet shows the 
product sales for Charlotte' Website. The first 
row is BOLD: it is the Header Row. There are 
many rows of data.

Memo to Self: You do not have to MATCH 
the numbers shown on these pages. It is 
more important that you begin with some 
data and understand the options.

Comma Training Page 14

Advanced Excel 2010 Page 14 of 298



Home -> Cells->Format->Move or Copy

Exam 77-882: Microsoft Excel 2010 Core
4. Managing Worksheets and Workbooks 
4.1. Create and format worksheets: Copy, Rename

Still Before You Begin
A good administrator makes a COPY of the 
data before manipulating it.

2. Try This: Copy the Spreadsheet
Go to Home -> Cells -> Format. 
Click on Move or Copy.
A new sheet will be inserted.

3. Try This: Rename the Worksheet
Click on the Original Data (2) tab.
Go to Home -> Cells -> Format. 
Click on Rename Sheet.
The Name in the tab should be highlighted 
black. Type:  Data Tables.
Click ENTER on the keyboard.

Keep going...

Memo to Self: You can achieve the same 
results by right-clicking the tab, as shown.
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Home -> Editing->Sort & Filter->Sort A to Z

Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.2. Sort data: Sort & Filter

Sort & Filter: A to Z
So, here is a list of clients that bought 
products from Charlotte's Website. The fields 
in the Header Row include the name, date, 
product and amount for the sales. 

4. Try This: Sort & Filter the Data
Select the entire spreadsheet. 
Go to Home -> Editing->Sort & Filter.
Select: Sort A-Z.

What Do You See? The data is sorted by the 
first Column. By default, the data is sorted 
alphabetically. So, the names of the months 
go from April (A) through September 
(S)....that's not what most people have in 
mind.

Try Again: Undo the last step and keep 
going.
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.2. Sort data: Sort data using single or multiple criteria 

Data -> Sort & Filter ->Sort

Data: Sort Order
There is another kind of Sort that can be 
found on the Data Ribbon. This Sort lets 
you use one or several criteria. The criteria 
comes from the names in the Header Row.

5. Try it: Data Sort
Select the whole spreadsheet.
Go to Data -> Sort & Filter ->Sort.

What Do You See? The options include:
Add Level
Delete Level
Copy Level
There should be a check mark for: 
My data has Headers.

Try This, Too: Edit the Sort Options
Sort by: Month
Sort On: Values
Order: Custom List (Remember, A to Z 
didn't work for Months. Keep going...)
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.2. Sort data: Sort data using single or multiple criteria 

Data: Custom Sort Criteria
What Do You See? Spreadsheets are used 
for financials and financials are recorded by 
date. Spreadsheets like Excel recognize that 
Months are sorted in calendar order, not 
alphabetically. Here are the steps:

6. Try it: Choose a Custom List
Select the spreadsheet.
Go to Data -> Sort & Filter ->Sort.
Go to Order-> Custom List.
Select: January, February, March, April...
This is the List that matches our data.

Click OK, then OK again to save and close 
both windows. The entire list has been 
sorted. Not bad, huh? 

Keep going....

The Computer Mama sez: In the 1980s, Fr. 
Paul wanted to sort 550 families on a PDP 11 
computer. It took most of the night.
Computers are faster now, aren’t they?

Data -> Sort & Filter ->Sort-> Order-> Custom List
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.2. Sort data: Sort data using single or multiple criteria 

Data -> Sort & Filter ->Sort-> Add Level

Data: Sort by Multiple Criteria
Sometimes, it is useful to Sort the information by 
more than one criteria. Say you wanted to see 
how much each sales rep sold by month. 

7. Try it: Sort by Multiple Criteria
Select the entire spreadsheet.
Go to Data -> Sort & Filter ->Sort.
The Order is Custom: January, February, 
March

Click on Add Level to add a second Row. 
Choose: Sales Rep
The Order is A to Z.

Click on Add Level again to add another Row. 
Choose: Date
The Order is Oldest to Newest.
Click OK. 
Keep going, please... 
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Summary of List Options
What Do You See?  The information was 
sorted to our criteria. However, it is very 
difficult to read and interpret the data. It all 
looks the same. This looks like a list with 
details, details and still more details. 

A Table is a easy to format and filter. You 
can also use a Table to calculate numbers in 
a Total Row. Interested? OK, start here...
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats: Format data as a table

Home->Styles->Format as Table

Format as Table
Rows and Columns can be organized into a 
Table. A Table has Properties that can be 
formatted much more easily than a List. Here 
are the steps to convert a List into a Table.

1. Try It: Format a Table
Go to Home->Styles.
Click on Format as Table.
Choose: Table Style Medium 4.

Where is the data for your table? 
You will be prompted to select the Range for 
you data. In the example on this page, Excel 
selected all of the Cells from $A$1:$H$69. 
The Range is Absolute.

What Else Do You See? There should be a 
check mark for My table has headers.

Go to the next page, please...
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats: Format data as a table

Table Tools->Design

Hello, Table!
2. What Do You See? The data has been 
formatted as a Table. The Header Row is 
Bold and it has little filters: Drop-down 
option lists. 

The rows of customer information have 
been formatted to make the data easier to 
read.

What Else Do You See? The Table Tools
should be available.

Keep going...

Where Have You Seen This Before?
Microsoft Word has Table Tools, as well. 
However, Word has two Ribbons: Design 
and Layout. Microsoft Excel already 
recognizes Rows and Columns, whereas 
Word has to define them with the Layout 
Ribbon.
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Use the Header Row
You can use the Header Row to Sort and 
Filter the data.

3. Try It: Use the Header Row Filters
Select the Sales Rep Filter.
Sort the Column A to Z.

Try This, Too: Filter the Data
Filter the Sales Reps: Connie and Niki. 

What Do You See? Only the Rows where 
Connie or Niki are the Sales Rep are shown. 
The other rows are hidden.

What Else Do You See? This table has 
Banded Rows. Does the formatting update 
when you choose different Filters?

Where Have You Seen This Before? The 
header row is used to create Mail Merge 
Fields in Microsoft Word, too.
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats: Format Table Styles

Table Tools->Design ->Table Styles

Table Styles
Formatting makes the data easier to 
read and understand.  Microsoft Excel 
2010 has a gallery of Table Styles
templates. The Table Styles format the 
Headers as well as the Columns and 
Rows.

Before You Begin: Please click 
anywhere on the Table to select it. The 
Table Tools should be visible.

4. Try It: Apply a Table Style
Go to Table Tools->Design.
Go to Table Styles.
Select a Quick Style from the gallery.

What Do You See? The Table Styles 
are grouped by Light, Medium and Dark.

What Else Do You See? The Sales 
Rep data is Filtered. There is a little 
funnel symbol on the field.

Keep going...
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats: Format Table Style Options

Table Tools->Design ->Table Style Options

Table Style Options
You can use the Table Style Options to 
display the Header Row, Total Row and 
formatting if you wish.

5. Try It: Add or Remove the Header
Go to Table Tools-> Design.
Look in the Table Style Options.
Uncheck the Header Row.

What Do You See? When you turn off the 
Header Row, the first row becomes blank. 
The Filter on Sales Rep is gone, too, so 
you should see all of the data.

Trust But Verify: Turn the Header Row 
back on, please. The Header and the 
Filters should be available again. 

Memo to Self: The Header Row Field 
Names are saved in the Table Properties.
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats: Format Table Style Options

Table Tools->Design ->Table Style Options

Table Style Options
Color is an effective method to indicate 
which data should get the most attention. 

Before You Begin: Please click 
anywhere on the Table to select it. The 
Table Tools should be available.

6. Try It: Edit the Table Style Options 
Go to Table Tools->Design.
Go to Table Style Options.
Select: Banded Rows.
Select: First and Last Column.

What Do You See? The Table Styles 
emphasized the first and last columns by 
formatting the Cells Bold. 

The Banded Rows make it easier to read 
across a Row.

You can keep going, there's more...
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats: Calculate data in a table

Table Tools->Design ->Table Style Options -> Total Row

Calculate the Totals
Adding a Total Row to the Table is as 
simple as checking the option. 

Before You Begin: Click on the Table. 
The Table Tools should be available.

7. Try It: Add a Total Row 
Go to Table Tools->Design.
Go to Table Style Options.
Select: Total Row.

What Do You See? By default, the Total 
Row will be added to the bottom of the 
Table. Microsoft Excel will insert a formula 
for your Total: $33,540.00. 

Keep going, OK?
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats: Calculate data in a table

Table Tools->Design ->Table Style Options -> Total Row

Edit the Total Row
Look at the Total Row: it has a summary 
function. You can change the operation 
from Sum to Average, Count, Max, Min or 
any of the options available in the 
extensive Excel library.

8. Try It: Edit the Total Row Function
Select: Cell H70. In this example, it is the 
Cell with the Total formula.

Select a Function: Average.

What Do You See? The average price 
will be calculated. 

Memo to Self: How would someone 
reading your spreadsheet know that this is 
the Average, and not the Sum? 
Labels, Labels, Labels.
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats: Modify a table

Home->Cells->Insert->Insert Table Rows Above

Add to the Table 
Is the Table flexible? Can you add another Row 
or Column to the Table without losing the 
formatting, totals calculations, or otherwise 
breaking it?

Try It: Add a Row
Select any Cell in the Total Row.
Go to Home -> Cells->Insert.
Click on Insert Table Rows Above.

What Do You See?  After you insert a new Row 
or Column, you may see a small format painter. 
You can click on the arrow and choose the 
formatting for the new Row.
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats: Clear the Table Styles

Table Tools-> Design ->Table Styles -> Clear

Conditional Formatting
People have a hard time reading 
numbers. You can use color to show 
trends or make comparisons, say High, 
Medium, and Low. Microsoft Excel calls 
this Conditional Formatting. The color 
depends on the condition, which you can 
choose. Let's look at the options.

1. Before You Begin: Clear the Styles
Click on the Table. The Table Tools 
should be available.
Go to Table Tools->Design.
Go to Table Styles -> Clear.

What Do You See? The Table Styles 
should be cleared. Keep going...
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.3. Apply conditional formatting: Top/Bottom Rules

Home-> Styles-> Conditional Formatting -> Top/Bottom Rules

Conditional Formats
Microsoft Excel has a library of Conditional 
Formatting including Data Bars, Color Sets 
and Icons. 

Each of these formats is based on 
Conditional Formulas, or Rules. Let's start 
with a simple Rule: show me any amount 
that is above the average.

2. Try It: Above or Below Average?
Select Column H
In the sample spreadsheet, this is the 
column with the Amount.

Go to Home ->Styles.
Go to Conditional Formatting.
Go to Top/Bottom Rules.
Select: Above Average. 

Keep going, you will be prompted...
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.3. Apply conditional formatting: Top/Bottom Rules

Choose the Formatting
What Do You See? You will be prompted 
to select the colors when you select a 
Top/Bottom Rule. 

In the example on this page, the 
suggested color is red, which isn't what 
people expect if the amount is ABOVE the 
Average.

Green means go: it is used to indicate 
financial success. 

3. Try It: Format Cells  
Select Green Fill with Dark Green Text, 
please. Click OK. The Amount in Column 
H will be formatted Dark Green if it is 
Above Average.

Home-> Styles-> Conditional Formatting-> Top/Bottom Rules
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.3. Apply conditional formatting: Top/Bottom Rules

Home-> Styles-> Conditional Formatting -> Top/Bottom Rules

More Than One Rule
You can have more than one Conditional 
Rule formatting your data. In this illustration, 
there is one color for sales that are Above 
Average, and another for the sales that are 
Below Average. 

4. Try It: Add Another Rule
Select Column H.
Go to Home -> Styles.
Go to Conditional Formatting.
Go to Top/Bottom Rules.
Select: Below Average. 

Format Cells: You will be prompted to select 
a formatting option. Select Red Fill with Dark 
Red Text, please.

What Do You See? Any amount less than 
the Average is highlighted red with red text. 
Any amount greater than the Average is 
formatted green/green. 

Keep going...(this is actually fun, isn't it?)
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.3. Apply conditional formatting: Clear Rules

Clear the Rules
The following pages will play with the various 
Conditional Formatting Rules. After each 
example, you can Clear the Conditional 
Formatting. Here are the steps. 

Try it: Clear the Conditional Formatting
Select Column H.
Go to Home ->Home -> Styles.
Go to Conditional Formatting.
Go to Clear Rules.
Select: Clear Rules from Selected Cells. 

What Do You See? You can Clear Rules 
from Selected Cells, the Entire Spreadsheet, 
from this Table or from a PivotTable.

Home-> Styles-> Conditional Formatting-> Clear Rules
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.3. Apply conditional formatting: Use Data Bars

Home-> Styles-> Conditional Formatting-> Data Bars

Data Bars
The following exercises demonstrate the 
various Conditional Formatting available 
in Microsoft Excel. All of these examples 
will be applied to the H Column, the one 
with sales data. The Amount has been 
Sorted Descending.

Try It: Format with Data Bars
Select Column H.
Go to Home -> Styles.
Go to Conditional Formatting.
Select: Data Bars.

What Do You See? The cell with the 
highest value is 100% filled in. The other 
cells are filled with less than 100%. Excel 
calculates the percentage.

After each trial, select the H Column.
Go to Conditional Formatting -> Clear 
Rules -> From the Selected Cells. 
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.3. Apply conditional formatting: Use Color Sets

Home-> Styles-> Conditional Formatting-> Color Scales

Use Color Scales
Try It: Format with Color Scales
Select Column H.
Go to Home-> Styles.
Go to Conditional Formatting.
Select Color Scales: you will have a short 
set of built-in options. 

What Do You See? The Color Scales use 
two colors to indicate the Conditional 
Formatting. In this example, the highest 
value is red and the lowest is yellow. 
Microsoft Excel compares each amount 
and formats the cells accordingly.

Try This, Too: What does it look like if 
you sort the information by Date?

After each trial, select the H Column.
Go to Conditional Formatting -> Clear 
Rules -> From the Selected Cells. 
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.3. Apply conditional formatting: Use Icon Sets

Home-> Styles-> Conditional Formatting-> Icon Sets

Use Icon Sets
Try It: Format with Icon Sets
Select Column H.
Go to Home -> Styles.
Go to Conditional Formatting.
Select Icon Sets: Arrows (Colored)

What Do You See? The Icon Sets use a 
three, four, or five-color scale to format 
the data. In the example on this page, 
there are four Directional arrows 
representing the following percents:
100-75%
74-50%
49-25%
25-0%

What Else Do You See? The Conditional 
Formatting menu also lets you create a 
New Rule or Manage the Rules. 

Let's investigate where Excel puts the 
Rules and what tools are available in the 
Rules Manager. Keep going...
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.3. Apply conditional formatting: Manage the Rules

Home -> Styles->Conditional Formatting  -> Manage Rules

The Rules Manager
Before You Begin: In this example, Column 
H is the Amount, sorted Descending. Column 
H has the Icon Set Conditional Formatting,

1. Try It: Use the Rules Manager
Go to Home -> Styles.
Go to Conditional Formatting.
Click on Manage Rules.

What Do You See? The Rules Manager
should display a list of the Conditional 
Formatting. You can add, delete, and edit the 
Rules here.

2. Try This, Too: Edit the Rule
Click on Edit Rule...

Keep going, pleeeeeease...
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.3. Apply conditional formatting: Manage the Rules

Home -> Conditional Formatting  -> Manage Rules

Bend the Rules
3. What Do You See? The Rule Type
is a list of options. You can use a Rule 
to identify a cell by the values. The 
values can be based on the average or 
the rank. You can also use a formula in 
a rule.

The Rule Description is a tool for 
defining the values. You can select the 
formatting Style and type in your own 
Value if you wish.

You can edit each part of the Rule 
Description including the Icons, the 
values and the colors if you wish. 

It's kind of fun. Click OK to return to the 
Rules Manager, and OK, again, to close 
the Rules Manager.

Very Good! 
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.3. Apply conditional formatting: Find Conditional Formatting

Home -> Editing ->Find & Select

Find Special Cells 
You can use the Find & Select option to 
locate cells with Conditional Formatting or 
Data Validation. 

The Find button is in the Editing group on 
the Home Ribbon. The Find icon may look 
different in Word and Excel (big or small), 
but in both programs it is still on the right 
side of the Ribbon.

Try This: Use the Find Options
Go to Home ->Editing.
Select Find and Select.
Click on Data Validation or Conditional 
Formatting and test the Find options.

Microsoft Excel will highlight the Cells with 
Conditional Formatting in Column H.
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats: Edit the Table Properties

Table Tools-> Design ->Properties-> Resize Table

Table Properties: Resize
The Table Tools include two more groups of 
options: Table Properties and Table Tools.  

Before You Begin: Review the Properties
The Table Properties include the Name and 
the Range. By default, the Table was named 
Table1 in this example. The Resize Table 
button lets you select the Range of Cells.

Try it: Resize the Table
Click anywhere on the Table. The Table 
Tools should be available.

Go to Table Tools-> Design ->Properties
Select Resize Table.

What Do You See? Microsoft Excel will 
outline the Range of the Table. In the 
example on this page, the Table is 
=$A$1:$H$71. The Range is in Absolute 
references. 

If you wish, you can select a new range, but 
the Header must stay the same.
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats: Remove duplicates in a Table

Table Tools-> Design ->Tools-> Remove Duplicates

Table: Remove Duplicates
When people enter data into a table or list, it 
is easy to make a mistake and type a name 
twice. Duplicates happen. In this example, we 
will copy and paste a Row, then go through 
the steps to find the duplicate. 

1. Try This: Create the Duplicate
Select Row 69
Go to Home->Copy.
Select Cell A70. (In our example, we added a 
new, blank Row 70 a few pages back.)
Go to Home->Paste.

What Do you See? The pasted Cells are a 
duplicate of the Row that you copied.

Keep going... 
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats: Remove duplicates in a Table

Table Tools-> Design ->Tools-> Remove Duplicates

Table: Remove Duplicates
2. Try This: Remove Duplicates
Click anywhere on the Table. The Table 
Tools should be available.
Go to Table Tools-> Design ->Tools.
Click on Remove Duplicates.

What Do You See? Each of the Columns in 
our table is selected. The Column Names 
come from the Header Row.

When you click on OK, the duplicates will be 
found and removed.

So, that's good, too.
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats: Convert a Table to a Range

Table Tools-> Design ->Tools-> Convert to Range

Convert to Range
This lesson began by creating a Table by 
selecting a Range of Cells. What if you 
wanted to remove the Table but keep the 
data? Here are the steps you can take to 
convert the table back to a Range, or List.

Try it: Convert the Table to a Range
Click anywhere on the Table. The Table 
Tools should be available.
Go to Table Tools-> Design ->Tools.
Click on Convert to Range.

What Do You See? You will be prompted 
that the Table will be converted to a 
normal range. None of the data should be 
lost when you convert to Range. 

The data will still have the Conditional 
Formatting, however the Filters at the top 
in the Header Row will be gone. 

Done and done. You get the cookie.

Comma Training Page 44

Advanced Excel 2010 Page 44 of 298



Lesson 1: It Works for Me!
Before You Begin: Download the sample spreadsheet: Student Records.xlsx

Try This: Do the following steps
1. Open the spreadsheet: Student Records.xlsx
2. Delete the columns for Grade and Homeroom Teacher
3. Add the following students to the bottom of the spreadsheet

Student Percent Class
Lauren Ball 96 2012
Brandon Ayers 45 2011
Arnold Johnston 78 2012
Brittney Evans 82 2013

4. Sort the Spreadsheet by Class
5. Format with Table Style Light 8 and select “My Table has Headers”
6. Use the Remove Duplicate Tool
7. Apply conditional formatting.  Create a new rule and select 2 color scale.  
    Pick red for the lowest value and green for the highest value.
8. Save this as YOUR NAME Works for Me Practice

Practice Activities
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8. The Find command can be used to find 
any cell(s) with Conditional Formatting 
applied.
a. True
b. False
Tip: Advanced Excel, page 40

9. Which is a type of Conditional Formatting? 
(Select all correct answers.)
a. Icon Sets
b. Color Scales
c. Data Bars
d. Fill & Text Colors
Tip: Advanced Excel, page 31

10. An Excel Table has a gallery of Table 
Styles.
a. True
b. False
Tip: Advanced Excel, page 24

5. Which is true about a Total Row in an 
Excel Table? 
(Select all correct answers.)
a. Created by checking Total Row on the 
Table Tools Ribbon
b. Includes a Summary box with a drop down 
list of options
c. Can only be used to calculate Sum
d. Can only be used on small tables
Tip: Advanced Excel, page 27, 28

6. Which are true about Conditional 
Formatting? (Select all correct answers.)
a. Colors or icons are based on rules
b. Command is Home->Styles->Conditional 
Formatting
c. Includes option for creating custom rules
d. Can only have one rule applied
Tip: Advanced Excel, page 31-33

7. Which commands are on the Table Tools 
ribbon? (Select all correct answers.)
a. Remove duplicates
b. Convert to Range
c. Insert Rows
Tip: Advanced Excel, page 44

1. Which of the following is a way to copy a 
sheet in a workbook? 
(Select all correct answers)
a. Home-> Cells-> Format-> Move or Copy
b. Right click the sheet and select Move or 
Copy
c. Save As-> Copy
Tip: Advanced Excel, page 15

2. When using the sort command on a 
column of Months, by default, the column is 
sorted alphabetically, with April first.
a. True
b. False
Tip: Advanced Excel, page 16

3. Where is the Sort command that allows for 
custom sorting of months?
a. Home-> Sort & Filter-> Custom Sort
b. Data-> Sort & Filter-> Sort-> Custom List
c. Data-> Sort & Filter-> Months 
Tip: Advanced Excel, page 18

4. Excel can makes tables of data.
a. True
b. False
Tip: Advanced Excel, page 21

Test Yourself

Assesment: Test your skills
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© 2011 Comma Productions

Excel 2010: Tables and Lists

Advanced Excel Objectives
In this lesson, you will learn how to: 
1. Use the Data Ribbon to Sort and Filter the data
2. Outline the data with the Outline Tools and use 
the Outline to Show or Hide Rows of information
3. Use the Data Tools to perform a What-If Analysis, 
for example use Goal Seek to define a total and see 
how that goal can be met
4. Use the Scenario Manage to define Best, Worst 
and Expected results by changing one or more cells

Work Smarter, Not Harder
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1. Readings
Read Lesson 3 in the Advanced Excel 
guide, page 47-80.

Project
A sample spreadsheet that uses Outlines 
and What-If Scenarios to analyze the data.

Downloads
Customer Sales 2010.xlsx
Legs Eggs Pigs 2010.xlsx
Brown Bag Lunch Sales Team.xlsx

2. Practice
Do the Practice Activity, page 81.

3. Assessment
Review the Test questions, page 82.

Menu Maps
This lesson shows the Data Ribbon.
1. Data->Sort and Filter->Sort, page 51
2. Data->Sort and Filter->Filter, page 52
3. Data -> Sort & Filter-> Clear, page 55
4. Data -> Outline-> Subtotal, page 56
5. Data -> Outline-> Subtotal->Group->Group, page 66
6. Data -> Data Tools->What-If Analysis-> Goal Seek, page 69
7. Data -> Data Tools->What-If Analysis-> Scenario Manager, page 71

Data
Lesson 3: Work Smarter, Not Harder
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Start Microsoft Excel
What Do You See? Is 
there a Title Bar that says 
Microsoft Excel? Yes.

Is there a Home Ribbon 
with the Clipboard, Font, 
Alignment and Number 
Groups? Yes.

If your screen looks similar 
to the example on this 
page, then you are ready 
to get started.

Start -> All Programs ->Microsoft Office-> Microsoft Office Excel 2010

Work Smarter, Not Harder
Pretend your little company recorded all of their invoices in a financial program. This software allowed you to export that information 
into Microsoft Excel. You have a lot of questions and Excel can help you analyze the data. Your goal is to look at the sales 
numbers. The invoices are sorted by month. For each record, can you see who sold what?  To whom?  For how much?
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File->Open

Before You Begin
The purpose of this lesson is to investigate 
the Data Options in Microsoft Excel 2010. 
You can use a spreadsheet that you created 
or download a sample spreadsheet if you 
wish.

1. Try This: Open a Sample Spreadsheet
Open a sample spreadsheet: 
Customer Sales 2010.xlsx
Go to the sheet called: Customer List.

2. What Do You See? This is the Customer 
List for Charlotte's Website. The first row is 
BOLD: it is the Header Row. There are many 
rows of data including Name, Address, 
Phone. This data came from a database, so 
Column A includes the unique CustomerID 
number.

Keep going...

Memo to Self: You do not have to MATCH 
the numbers shown on these pages. It is 
more important that you begin with some 
data and understand the options.
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.2. Sort data using single or multiple criteria 

Data: Sort 
This lesson will investigate the Data Ribbon: 
Sort, Filter and Subtotal. Each Data command 
adds to your understanding of the numbers. 
Each option also has it's limits: it can only do "so 
much." 

When you Sort the data, you can find patterns. 
For example, the customer information might 
make sense when it is sorted by City.

1. Try This: Sort the Data 
Select the entire spreadsheet.
Go to Data ->Sort and Filter.
Click on Sort. When you are prompted choose:
Sort by: City
Sort On: Values.
Order: A to Z.

What Do You See? This Sort organized the 
customers by one criteria: City.  Keep going...

Data->Sort and Filter->Sort
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.1. Filter data

Data: Filter
A Filter is a way to separate the customers 
you want to see from the ones you don't want 
to see. In Microsoft Excel, the Filters show or 
hide the Rows based on your criteria.

When you Filter the data, you can focus on 

Select Row 1.
Go to Data -
Click on Filter.

Keep going...

Data->Sort and Filter->Filter
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.1. Filter data: Filter Lists with AutoFilter

Data: Text Filters
What Do You See? Look at the first row 
of this spreadsheet.  Each of the labels in 
the Header Row should have little drop-
down arrows. These are the filters.

3. Try This: Use an AutoFilter
Click on the City Filter.
Select one city: MyTown.
Click OK to apply the filter.

Keep going, please...

Data -> Sort & Filter-> Filter
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.1. Filter data: Apply Filter

Date: Apply the Filter
4. What Do You See?  Each column 
that has a Filter has a small icon.  
When you run your mouse over the 
Filter, you should see what the Filter 
equals.

A Filter is a query, or question, 
regarding your data. You can create 
Custom Filters by combining several 
filters on the same data.

What Else Do You See? Look at the 
bottom of the spreadsheet. The Status 
Bar in this example indicates that there 
are 450 customers in MyTown, out of 
770 records. The Rows are blue to 
show that there are hidden rows.

Data -> Sort & Filter-> Filter
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.1. Filter data: Clear a Filter

Data: Clear the Filters
You can clear the data filters if you 
wish. Here are the steps.

5. Try it: Clear the Filters
Select Column E (City).
Go to Data -> Sort & Filter. 
Click on Clear.

What Do You See?  This option 
removes all of the Filters on the City 
field. In the example on this page, the 
filter for MyTown has been cleared, so 
you can see other cities as well.

Very good. That's a short discussion 
on Filters. Save your work.

Data -> Sort & Filter-> Clear
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.1. Filter data: Clear All Filters

Data: Subtotals 
A Subtotal organizes and summarizes lists 
of data. The Subtotal function offers more 
options than calculating the Total in a Table. 
Subtotals can include Summary Functions 
(SUM, AVERAGE, COUNT) as well as a 
Grand Total.

There are two steps to creating a Subtotal:
1. Sort by the field you want.
2. Subtotal by the same field.

Before You Begin: Copy the Worksheet
Right-click the Customer List tab.
Click on Move or Copy.
Check: Create a Copy.
Click OK to create the copy.
Rename the sheet: Subtotal by City.

Still Before You Begin: Clear All Filters
Go to the Subtotal by City sheet.
Select Row 1.
Go to Data -> Sort & Filter-> Filter.

All Filters should be cleared from the Header 
Row. Keep going, please...

Data -> Sort & Filter-> Filter
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.2. Sort data

Data: Sort then Subtotal
The key to making the Subtotal 
function work is to match, match, 
match. You need to Sort and Subtotal 
by the same field. Before you create 
a Subtotal you need to Sort the 
data. 

1. Try it: Sort the Data
Select the entire spreadsheet.
Go to Data -> Sort & Filter-> Sort.
Sort by: City.
Sort On: Values.
Order: A to Z.
Click OK.

Keep going...

Data -> Sort & Filter-> Sort
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Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.2. Apply data analysis: Subtotal

Data: Subtotal
The list has been Sorted by City. Now, 
here are the steps to Subtotal by City.

2. Try it: Subtotal the Data
Select Column E (City).
Go to Data ->Outline->Subtotal.

You will be prompted to answer the 
following questions for this Subtotal:

At each change: City. 
You just sorted by City, select City for the 
Subtotal so it matches.

Use function: Count.

Add the subtotal to: City.
The Subtotal is counting the number of 
customers in each city. It makes sense to 
add the Subtotal to the City.

Click OK. Keep going...

Data -> Outline-> Subtotal
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Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.2. Apply data analysis: Subtotal

Hello Subtotals!
3. What Do You See? This spreadsheet 
now has Subtotals that count the number 
of customers in each city. There is also a 
Grand Total that adds up all of our 
customers in all of the cities.

What Else Do You See? Microsoft Excel 
created formulas for the Subtotals. Scroll 
down and select any Subtotal. Please 
review the formula. This example shows:
=SUBTOTAL(3,F2:F245)

Impressive.

Keep going...

Data -> Outline-> Subtotal
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Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.2. Apply data analysis: Subtotal Outlines

Viewing the Subtotals
The information is outlined on the left 
hand side of the spreadsheet. 

You can use the outline to show or hide 
the details. The + sign means there is 
more to see. The – sign indicates that all 
of the Rows are shown. 

4. Try It: Use the Outline
Click on the 3. All Rows are visible.
Click on the 2: That's the Subtotals.
Click on the 1. That hides all of the Rows 
except the Grand Count.

Made You Look: In this image, you are 
looking at Column E, so that it will fit on 
the page, OK?

Data -> Outline-> Subtotal
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File -> Open

A Different Subtotal
The Intermediate Guide to Microsoft Excel 
2010 demonstrated a series of formulas that 
calculated and formatted the sales subtotals. 

This lesson demonstrates how the sales 
subtotals were created. 

1. Try This: Open a Sample Spreadsheet
Open a sample spreadsheet: 
Customer Sales 2010.xlsx
Go to the sheet called: Monthly Sales.

What Do You See? This is the Monthly 
Sales for Charlotte's Website. The first row is 
BOLD: it is the Header Row. There are many 
rows of data including the Category, Service, 
Product, Date, Sales Rep and Amount.

Keep going...

Memo to Self: You do not have to MATCH 
the numbers shown on these pages. It is 
more important that you begin with some 
data and understand the options.
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Exam 77-882: Microsoft Excel 2010 Core
8. Analyzing and Organizing Data
8.2. Sort data

Data -> Sort & Filter-> Sort

Data: Sort Then Subtotal
This Subtotal will calculate the sum of the 
amount each Sales Rep sold. So, Sort by 
Sales Rep and Subtotal by Sales Rep.

2. Try it: Sort the Data
Select the entire spreadsheet. 
Go to Data -> Sort & Filter-> Sort.
Sort by: Sales Rep. 
Sort on: Values
Order: A-Z.
Click OK. 

What Do You See? The data will be 
sorted by the four Sales Reps: Alex, 
Connie, Elizabeth and Niki. 

Keep going...
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Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.2. Apply data analysis: Subtotal

Data -> Outline-> Subtotal

Data: Subtotal
Sort by Sales Rep. Subtotal by Sales 
Rep.

3. Try it: Subtotal the Data
Select the entire spreadsheet. 
Go to Data -> Outline-> Subtotal.

You will be prompted to answer the 
following questions for this Subtotal:

At each change in: Sales Rep. 
You just sorted by Sales Rep, select 
Sales Rep for the Subtotal so it matches.

Use function: Sum.

Add the subtotal to: Amount.

Click OK. Keep going...
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Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.2. Apply data analysis: Subtotal

Sales Subtotals
4. What Do You See? The screen shot on 
this page shows the Subtotals that each 
sales reps sold. The Subtotals are calculated 
and shown in Column H, Amount. There is a 
Grand Total for the entire Amount sold. 

The Outline is shown as Level 2. However, 
the data for Niki is expanded so that you can 
see the Rows that add up to her Subtotal.

So, the Subtotal function is an interactive 
display. You can use the Outline buttons to 
expand (+) or collapse (-) the Subtotal 
Groups to see the data if you wish. 

Do This: Save your spreadsheet
Go to File->Save As.
Browse for a folder to save this file.
Enter a file name: MyName Customer Sales.

Good.

Data -> Outline-> Subtotal
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Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.2. Apply data analysis: Subtotal

Data: Remove the Subtotal
The previous pages demonstrated how to 
create and edit Subtotals. Here are the steps 
you can take to Remove a Subtotal.

Try it: Review the Subtotals
Select the entire spreadsheet.
Go to Data -> Outline-> Subtotal

What Do You See? You will be prompted to 
fill in the blanks for the Subtotal function. 
Look at the bottom of the window. There is an 
option that you can click to remove the 
Subtotal.

Try This, Too: Remove the Subtotals
Select: Remove All.
Click OK. 

The Subtotals should be removed. This is a 
simple list in Excel, again. Very good.

Data -> Outline-> Subtotal->Remove All
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3.2. Apply data analysis: Group

Data: Group and Ungroup
Outline Functions: Subtotal is an excellent 
Outline tool. It allows you to show or hide the data 
depending on what you want to see. Another 
Outline function you could try is Group. Group 
creates an Outline on the left side of the 
spreadsheet, however it does not calculate the 
totals.

1. Try it: Group the Rows
Go to the Monthly Sales sheet.
Select Rows 2 and 3 (The data for January).
Go to Data -> Outline->Group.
Click on Group.

2. What Do You See? The two rows will be 
grouped together. There should be an outline on 
the left side of your spreadsheet.

Done and done.

Data -> Outline->Group->Group

Comma Training Page 66

Advanced Excel 2010 Page 66 of 298



Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.2. Apply data analysis: Data Tools What-If Analysis

Data: Data Tools
This page begins a new discussion on the 
Data Tools. Data Tools analyze the 
information: they ask questions. 

The best known Data Tool is the What-if? 
Analysis. Our lesson will begin with Goal 
Seek, a simple What-If.

Before You Begin: Open a Sample File
Open a sample spreadsheet: 
Legs Eggs Pigs 2010.xlsx
Go to the sheet: Pig.

What Do You See? This is the Pig Sales for 
Charlotte's Website. There are three 
reference Cells for Price (B1), Start (B2) and 
Increment (B3). The formulas in Columns C, 
D, and E refers to these three reference 
Cells.

Keep going...

Data -> Data Tools
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Data Tools: Goal Seek
Goal Seek asks the question backwards, 
starting from the answer. In this spreadsheet, 
the question is: how much money did you 
make? The answer is the SUM in Cell E25.

In this sales spreadsheet, Goal Seek asks: 
How much do you want to make? 
Which value do you want to change: Price, 
Start or Increment?

Keep going, please...

Data -> Data Tools
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Data: What If? Goal Seek
Here are the steps to try a Goal Seek.

1: Try It: Select the Goal
Go to the Pigs spreadsheet.
Select: Cell E25.
Go to Data -> Data Tools->What-If Analysis.
Click on Goal Seek.

2. Try This: Define the Options
You will be prompted to fill in the blanks:
Set cell: E25 (the SUM of the sales).
To value: 12000 (the Goal you want to make).
By changing cell: $B$1 (the Price)

Click OK...keep going.

Data -> Data Tools->What-If Analysis-> Goal Seek
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Data: Goal Seek Options
3. What Do You See? The Goal Seek Status
shows the Target Value of 12000. The Current 
Value in Cell E25 is set to $12,000. 

What Else Do You See? The Price in Cell B1 
changed from $3.25 to 4.355717. This is the 
new Price you need to reach the goal of 
$12,000 in sales. If you click OK, the new Price 
in Cell B1 will be kept. 

Do This, Please: Click CANCEL to undo the 
changes made by the Goal Seek.

Memo to Self: The Price in Cell B1 looks odd 
with all the decimal places. You can format Cell 
B1 for currency if you wish.

Data -> Data Tools->What-If Analysis-> Goal Seek
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Data Tools: What If Scenarios
Goal Seek changes one value. It is a useful 
tool for playing with the numbers. Suppose 
you wanted to look up the best and worst 
cases for your sales projections. You could 
type in a robust initial sales number and a 
vigorous daily increment for the best case. 
Then, you could type in more conservative 
estimates for the worst case. 

Microsoft Excel has a way to save that 
information: What-If Scenarios. 

1. Try it: Open the Scenario Manager
Select Cell E25.
Go to Data ->Data Tools->What-If Analysis.
Select Scenario Manager.

What Do You See? When the Scenario 
Manager opens it will probably be blank: No 
Scenarios defined.

Try This, Too: Add a Scenario
Click on Add. Keep going,,,

Data -> Data Tools->What-If Analysis-> Scenario Manager
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Add: Edit the Scenario 
2. What Do You See? You will be 
prompted to Edit the Scenario. 

Please enter the following:
Scenario Name: Expected Price
Changing Cells: $B$1
You can click on Cell B1, the Price, or 
type the reference if you wish. This is an 
Absolute Reference.

Click OK. Keep going...

Data -> Data Tools->What-If Analysis-> Scenario Manager
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Enter the Values 
3. Try This: Enter the Values
When you are done editing the Scenario 
and click OK, you will be prompted to 
Enter a value. Please type in 3.25. 

Click OK, again and you will return to the 
Scenario Manager. 

This step makes a benchmark: It records 
the spreadsheet the way we started The 
Price is $3.25. In the next pages, we will
Add a Scenario for Worst Case and on for 
the Best Case Scenario.

Each of these examples will change one 
Reference Cell-the Price in Cell B1. At the 
end of this lesson, we see how to create a 
Scenario with more than one reference 
Cell. 

So, keep going.

Data -> Data Tools->What-If Analysis-> Scenario Manager
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Add Another Scenario
At this point, the Scenario Manager has one 
Scenario: the Expected Price. Here are the 
steps to Add another Scenario.

4. Try This: Add Another Scenario
The Scenario Manager is open.
Click on: Add

You will be prompted to fill in the blanks:
Scenario Name: Best Case
Changing Cells: $B$1
You can click on Cell B1, the Price, or type 
the reference. This is an Absolute Reference.

Click OK. When you click on OK, the 
Scenario Manager will prompt you to enter a 
new value for each reference cell. 

Try This, Too: Enter the Scenario Value
Scenario Value for $B$1: 5.00

Keep going...

Data -> Data Tools ->What-If Analysis -> Scenario Manager
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Add Yet Another Scenario
Now there are two Scenarios: Expected Price 
and Best Case. Here are the steps to Add the 
Worst Case Scenario. When all 3 Scenarios 
are done, you'll see how it works... and it 
really does work well.

5. Try This: Add Yet Another Scenario
The Scenario Manager is open.
Click on: Add

You will be prompted to fill in the blanks:
Scenario Name: Worst Case
Changing Cells: $B$1
You can click on Cell B1, the Price, or type 
the reference. This is an Absolute Reference.

Click OK. When you click on OK, the 
Scenario Manager will prompt you to enter a 
new value for each reference cell. 

Try This, Too: Enter the Scenario Value
Scenario Value for $B$1: 2.00

Keeeeeeep going...

Data -> Data Tools ->What-If Analysis -> Scenario Manager
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Show the Scenario 
The Scenario Manager has three different 
Scenarios: Best, Worst and Expected. How 
does it work? Say you wanted to show off the 
Best Case Scenario. Here are the steps.

6. Try it: Show the Scenarios
Select a Scenario: Best Case
Click on Show.

The Price in Cell B1 changed from $3.25 to 
$5.00. All of the formulas in Column E 
updated and used the new Price to calculate 
the Revenue. Yeah!

Try This, Too: Show Another Scenario
Select a Scenario: Worst Case
Click on Show.
The Price in Cell B1 changed from $5.00 to 
$2.00. Boo Hoo.

And Try This: Show A Different Scenario
Select a Scenario: Expected Price. 
Click on Show....Very Good.

Data -> Data Tools ->What-If Analysis -> Scenario Manager
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A Different Scenario 
Say you wanted to create a Scenario that 
changed everything: the Price, the Start and 
the Increment. The next couple of pages 
show how to add more than one reference 
cell.

1. Try it: Create a Different Scenario
The Scenario Manager is open.
Click on: Add

You will be prompted to fill in the blanks:
Scenario Name: Change Everything
Changing Cells: $B$1
You can click on Cell B1, the Price, or type 
the reference. This is an Absolute Reference.

Add More Cells to the Scenario:
With your cursor next to $B$1,
Type a comma (,) and add $B$2, the Start
Type a comma (,) and add $B$3, Increment

Click OK. Keep going...

Data -> Data Tools ->What-If Analysis -> Scenario Manager
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More Than One Value 
When you click on OK, the Scenario Manager 
will prompt you to enter a new value for each 
reference cell. 

2. Try it: Edit the Values
Scenario Value for $B$1: 6.00
Scenario Value for $B$1: 200
Scenario Value for $B$1: 20

Click OK to return to the Scenario Manager.

Try This, Too: Add One More Scenario
Click on: Add

You will be prompted to fill in the blanks:
Scenario Name: Change Back
Changing Cells: $B$1, $B$2, $B$3

Now, Try it: Edit the Values
Scenario Value for $B$1: 5.00
Scenario Value for $B$1: 100
Scenario Value for $B$1: 5

Keep going...

Data -> Data Tools ->What-If Analysis -> Scenario Manager
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Show and Tell 
3. Try it: Show the New Scenarios
Select a Scenario: Change Everything
Click on Show.

The numbers in Cells B1, B2 and B3 
changed. All of the formulas in Column E 
updated and used the new data to calculate 
the Revenue. 

Try This, Too: Show Another Scenario
Select a Scenario: Change Back
Click on Show.
The numbers in Cells B1, B2 and B3 
changed back. All of the formulas in Column 
E updated and recalculated the Revenue.

That's Scenarios: a useful tool for analyzing 
your data. You can save your spreadsheet.

Data -> Data Tools ->What-If Analysis -> Scenario Manager
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Summary 
This lesson began with a discussion of the 
simple Outline Tools: Group, Outline and 
Subtotal. The purpose of these tools is to 
organize and visualize the data.

The lesson continued with the Data Tools. 
Our What-If Analysis included Goal Seek, for 
when you already have an answer in mind. 

The other analytical tool is the Scenario 
Manager. We walked through several 
different Scenarios that changed the 
Reference Cells.

Well, you done good.
Go get two cookies.

Data
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Lesson 2: Work Smarter, Not Harder
Before You Begin: Download the sample spreadsheet: Brown Bag Lunch Sales Team.xlsx

Try This: Do the following steps
1. Open the Spreadsheet: Brown Bag Lunch Sales Team.xlsx
2. Sort the spreadsheet by Product in ascending order
3. Create a Group with the Detroit Agents
4. Hide the Detroit Agents.
5. Filter Products so only Coffee & Donuts are visible.
6. Use the Goal Seek function on John Cook (Northern Michigan Market). 
  Set the value in column F to be $65,000 by changing the project income (Column E). 
  Click OK to accept the Goal Seek. 

7. Save this file as YOUR NAME Works Smarter Practice

Practice Activities
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8. Which of the following is true about the 
Goal-Seek command? 
(Select all correct answers.)
a. OK keeps the changes
b. Cancel rejects (or undoes) the 
changes
c. Apply keeps the changes
Tip: Advanced Excel, page 70

9. To enter multiple values for a What-if 
scenario, which is the best tool?
a. Goal-Seek
b. Scenario Manager
Tip: Advanced Excel, page 71

10. A What if Scenario can only change 
one (1) reference cell.
a. True
b. False
Tip: Advanced Excel, page 77

5. Which of the following are true about 
Subtotals? (Select all correct answers.)
a. To use the subtotal, data must be 
sorted first
b. The command is Data-> Outline-> 
Subtotal
c. The subtotal function creates totals for 
each group in the column
Tip: Advanced Excel, page 58

6. In the Outline a + indicates what?
(Select all correct answers.)
a. There is more data to see
b. All data is displayed
c. The outline can be expanded
d. The outline can be condensed
Tip: Advanced Excel, page 64

7. Which of the following are Outline 
functions? (Select all correct answers.)
a. Subtotal
b. Group
c. Sort
Tip: Advanced Excel, page 66

1. Which of the following is true? 
(Select all correct answers.)
a. Sort helps find patterns
b. Filter focuses on just part of the 
information
Tip: Advanced Excel page 51, 52

2. When the filter command is applied, 
the header row contains drop down filter 
options.
a. True
b. False
Tip: Advanced Excel, page 53

3. The status bar displays how many 
filtered records there are.
a. True
b. False
Tip: Advanced Excel, page 54

4. The Group command creates an 
outline in the side of the spreadsheet, but 
does NOT calculate totals.
a. True
b. False
Tip: Advanced Excel, page 66

Test Yourself

Assesment: Test your skills
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Analyzing Data Visually

PivotTables: What Happened?
Advanced Excel Objectives
In this lesson, you will learn how to: 
1. Identify the steps needed to create a PivotTable

2. Use Row Labels to filter the data

3. Use the Field Settings to Count Values

4. Pivot the Table!
5. Format the PivotTable and Pivot Table Reports
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PivotTable Tools->Design

PivotTable Tools->Options
1. Readings
Read Lesson 3 in the Advanced Excel 
guide, page 83-116.

Project
A spreadsheet that works with PivotTables in 
Excel. This lesson shows how to present data 
visually, format data as a PivotTable and display 
the Totals.

Downloads
Sales Data 2010.xls
Brown Bag Lunch Sales Team.xlsx

2. Practice
Complete the Practice Activity on page 117.

3. Assessment
Review the Test questions on page 118.

Menu Maps
This lesson demonstrates the Pivot Table Tools Design and Options Ribbons.
1. PivotTable Tools ->Options-> Show-> Field List, page 90
2. PivotTable Tools ->Options-> Show> Field Headers, page 93
3. PivotTable Tools ->Options-> Active Field-> Field Settings, page 96
4. PivotTable Tools ->Design-> Layout-> Subtotals, page 104
5. PivotTable Tools ->Design-> Layout->Blank Rows, page 105
6. PivotTable Tools ->Design-> Layout-> Grand Totals, page 106
7. PivotTable Tools ->Design-> Layout->Report Layout, page 110
8. PivotTable Tools ->Design-> PivotTable Styles->Style, page 111
9. PivotTable Tools ->Design-> PivotTable Style Options, page 112
From the Insert Ribbon
Insert->Tables->Pivot Table, page 87

Lesson 3: Pivot Tables: What Happened?
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Start Microsoft Excel
What Do You See? Is 
there a Title Bar that says 
Microsoft Excel? Yes.

Is there a Home Ribbon 
with the Clipboard, Font, 
Alignment and Number 
Groups? Yes.

If your screen looks simila
to the example on this 
page, then you are ready 
to get started.

Start -> All Programs ->Microsoft Office-> Microsoft Office Excel 2010

The Right Tool for the Task
The Data Tools are: Sort, Filter, Group and Subtotal. A PivotTable combines all of the best Data Tools 
together. A PivotTable presents the data in a visual, interactive format. PivotTables summarize, sort, compare 
and filter the data. For some reason, most people teach PivotTables as an advanced topic. In this lesson, 
"advanced" doesn't mean difficult: just more steps. The Computer Mama sez formulas can be difficult. This is 
actually fun. Try it.
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File -> Open

Before You Begin
The purpose of this lesson is to investigate 
the PivotTable Options in Microsoft Excel 
2010. You can use a spreadsheet that you 
created or download a sample spreadsheet if 
you wish.

1. Try This: Open a Sample Spreadsheet
Open a sample spreadsheet: Sales2010.xlsx
Go to the Original Data sheet.

What Do You See? This sheet shows the 
product sales for Charlotte' Website. The first 
row is BOLD: it is the Header Row. There are 
many rows of data.

Memo to Self: You do not have to MATCH 
the numbers shown on these pages. It is 
more important that you begin with some 
data and understand the options.
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Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.3. Apply and manipulate PivotTables

Insert ->Tables-> PivotTable

Insert a Pivot Table 
A PivotTable summarizes data and 
displays the results. It is a reporting 
tool that works very well. Here is how 
you start.

2: Try This: Insert a PivotTable
Go to the Monthly Sales spreadsheet.
Select all.
Go to Insert ->Tables.
Click on PivotTable.

Keep going...
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3. Presenting Data Visually
3.3. Apply and manipulate PivotTables

Insert ->PivotTable

Create a PivotTable
3. Try This: Choose the data
If you selected the entire Monthly 
Sales sheet, Excel will display the 
Table or Range: 'Monthly Sales'!$A:$H

In words, that means "name of your 
spreadsheet" ! "all of the data in 
Column A through Column H."

Try This, Too: Where do you want to 
place the new PivotTable report? The 
choices are create a new PivotTable in 
a new worksheet or place it on an 
existing worksheet.

Select: New Worksheet.
Click OK. 

Keep going...
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3.3. Apply and manipulate PivotTables

Hello, PivotTable
4. What Do You See? When you 
click on OK, Microsoft Excel will 
create a new, blank PivotTable in a 
new worksheet. The Pivot Table 
Tools should be available. There 
are two PivotTable Ribbons: 
Options and Design.

The Options Ribbon includes:
PivotTable
Active Field
Group
Sort and Filter
Data
Actions
Calculations
Tools
Show/Hide

The Design Ribbon includes:
Layout
PivotTable Style Options
PivotTable Styles

Keep going, please...

Insert ->Tables->PivotTable
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3.3. Apply and manipulate PivotTables: Show the Field List

PivotTable Fields 
5. What Else Do You See? There are 
three parts to a spreadsheet: Labels, 
Data, and Formulas. In this example the 
labels includes Category, Service, 
Product, Date, Sales Rep and Amount. 
These labels will become the fields in the 
PivotTable.

PivotTables use fields to organize and 
calculate the rows and columns. These 
fields come from the labels in the first row 
(the header) in the spreadsheet. 

Look for the PivotTable Field List on the 
right side of your screen. How do the 
fields compare to your labels?

Keep going...

What If You Don't See It? The Field List 
can be turned on or off with the 
PivotTable Tools. If you don't see the 
Field List:
Go to PivotTable Tools ->Options.
Go to Show-> Field List.

PivotTable Tools ->Options-> Show-> Field List
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PivotTable: Add Fields
Creating a PivotTable begins by adding 
fields to the table. Every table calculates 
something: SUM, COUNT, AVERAGE, 
etc. In this example, we'll answer the 
question: what did you sell?

6. Add Fields to the PivotTable
Go to the PivotTable Field List.
Select: Product. 

What Do You See? Look at the new 
PivotTable on the left side of the 
spreadsheet. The Products should be 
displayed in the PivotTable.

Keep going...

PivotTable Tools ->Options-> Show-> Field List
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3.3. Apply and manipulate PivotTables

PivotTable: Row Labels 
7. What Else Do You See? Please 
look at the bottom of the Field List. 

The Product field was added to the 
Row Labels. 

Keep going...

PivotTable Tools ->Options-> Show-> Field List
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PivotTable: Field Headers
Row Labels are Filters. The top row of 
the PivotTable is the Row Label: this is 
the Field Header. You can use the Field 
Header to display all of the products in 
the PivotTable or just a few if you wish. 

8. Try This: Filter the Data
Click on the Row Labels.
Select: Edible Fruit
Select: Fruit and Veggies.
When you click OK, the PivotTable will 
display those two products.

Try This, Too: Show All of the Data
Click on the Row Label:
Select: (Select All)
Click OK. Keep going...

What If You Don't See It? The Field 
Headers can be turned on or off with the 
PivotTable Tools. If you don't see the 
Field List please try this:
Go to PivotTable Tools ->Options.
Go to Show-> Field Headers.

PivotTable Tools ->Options-> Show> Field Headers
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PivotTable: Field Values
PivotTables need data. When you add 
Values, you can do calculations. The 
following pages will focus on the options 
at the bottom of the Field List.

Before You Begin: When you review the 
data in the sample spreadsheet, there are 
a couple of fields that make sense to use 
to COUNT or SUM the Values. 

There are many Products in each 
Category. This is a many-to-many 
relationship. 

There is one Amount for each sale. This a 
one-to-one relationship.

1. Try This: Add a Value
Go to the Field List
Drag and Drop Amount to the Values.

(Yes, it may say Count of Amount. 
Keep going...)

PivotTable Tools ->Options-> Show> Field List
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3. Presenting Data Visually
3.3. Apply and manipulate PivotTables: Values

PivotTable: Values
2. What Do You See? When you add the 
Value, the PivotTable will automatically 
count the records for each row. There is a 
Grand Total for all of the Products, too.

Count is the default field value. What are 
the other options? Keep going...

PivotTable Tools ->Options-> Show> Field List
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3.3. Apply and manipulate PivotTables: Field Settings

Edit the Field Settings
3. Try This. Change the Field Settings
Select Cell B3: Count of Amount.
Go to PivotTable Tools ->Options.
Go to the Active Field group.
Select: Field Settings.

Keep going...

Memo to Self: In this example, the easy 
way to open the Field Settings is to 
double-click the Count Of Amount Field 
Header on the PivotTable. 

PivotTable Tools ->Options-> Active Field-> Field Settings
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Value Field Settings
A PivotTable can use these functions:
Sum
Average
Max
Min
Product
Count Numbers
StvDev
StDevp
Var and Varp

4. Try This: Choose the Calculation
Select Sum from the options.
The Custom Name should update to Sum 
of Amount.

Click OK and keep going...

Memo to Self: You can summarize the 
values as a percent of the row, column, 
group or total. You can also display the 
values as the difference, % of difference 
or running total if you wish.

PivotTable Tools ->Options-> Active Field-> Field Settings

Comma Training Page 97

Advanced Excel 2010 Page 97 of 298



Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.3. Apply and manipulate PivotTables: Field Settings

Sum of Amount
5. What Do You See? When you change 
the Field Settings from Count to Sum the 
PivotTable will update the calculations. 

The example on this page shows the 
sales amounts, although the numbers 
may look odd because the amounts are 
not formatted for currency.

Do This: Save Your Spreadsheet
Go to File-> Save.
Browse to your documents folder.
File Name: My Name Customer Sales.
Click OK to save the file.

PivotTable Tools ->Options-> Active Field-> Field Settings
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PivotTable: Column Header
We began this PivotTable to answer the 
question: what did you sell? The next 
question would be: Who bought what? 

In this spreadsheet, the clients are tagged 
as Corporate, Education, Government 
and Private in the Category field. So, how 
many Breakfast Buffets were served to 
our corporate clients? Who bought what?

The Category field will be added to the 
Column Header. Here are the steps.

Before You Begin: Select the PivotTable. 
The PivotTable Tools should be available.

1. Try it: Add Another Field
Go to the PivotTable Field List.
Drag the Category to the Column Label.

Keep going, please...

PivotTable Tools ->Options-> Show> Field List
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3.3. Apply and manipulate PivotTables: Column Header

Column Headers
2. What Do You See? This PivotTable 
now has a Column Header that 
shows the Categories in Columns. 
There is a Subtotal for each category: 
Corporate, Educational, Government, 
Private. These are the Column 
Labels.

What Else Do You See? Cell B3 is 
the Filter for the Column Labels.

Keep going...

Memo to Self: These numbers may 
look odd because they are not 
formatted for currency.

PivotTable Tools ->Options-> Show> Field List
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3. Presenting Data Visually
3.3. Apply and manipulate PivotTables

Pivot the Table
What is a PivotTable, anyways? To Pivot 
means to move the data from the Rows 
into the Columns. This is cool.

Before You Begin: Select the PivotTable. 
The PivotTable Tools should be available.

3. You Gotta Try This: Pivot the Table!
Go to the Field List
Drag and Drop the Category Field from 
the Column Labels to the Row Labels.

Make sure the Category is ABOVE the 
Product field.

Really, keep going...

PivotTable Tools ->Options
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PivotTable: Display
4. What Do You See? There are four 
Categories. Each Category has a 
Subtotal. The names and the sum of the 
amounts for each Product sold is listed in 
alphabetical order in the client categories.

What Else Do You See? The Row Labels in 
Cell A3 have Filters. You can use the filter to 
show some or all of the Categories.

This is a good place to pause and try that 
again. Try switching the fields from the Row 
Labels to the Column Labels. Look at the 
PivotTable and see which way is easiest to 
read, which way makes more sense.

Then, Save.

Memo to Self: These numbers may look odd 
because they are not formatted for currency.

PivotTable Tools ->Options
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PivotTable Design
There are two sets of PivotTable Tools. The 
following pages will walk through the 
PivotTable Tools Design Ribbon. 

Review the Design Ribbon
The Layout Group lets you format the:
Subtotals
Grand Totals
Report Layout
Blank Rows

The PivotTable Style Options are:
Row Headers
Column Headers
Banded Rows
Banded Columns

Keep going...

PivotTable Tools ->Design-> Layout
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Design Layout: Subtotals
By default, a PivotTable displays the 
Subtotals at the top of a Group. You can 
change the Layout with the PivotTable 
Design Ribbon. Here are the steps:

Before You Begin: Select the PivotTable. 
The PivotTable Tools should be available.

Try it: Change The Subtotal Layout
Go to PivotTable Tools ->Design.
Go to Layout-> Subtotals.
Select: Show all Subtotals at Bottom of 
Group. 

What Do You See: The Subtotal options 
include the following:
Do Not Show Subtotals
Show all Subtotals at Bottom of Group 
Show all Subtotals at Top of Group 
Include Filtered Items in Totals

PivotTable Tools ->Design-> Layout-> Subtotals
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Layout: Blank Rows
This PivotTable is an Outline with a 
couple of groups: Category and Products. 
You can add Blank Rows between the 
groups to make the PivotTable easier to 
read. 

Before You Begin: Select the PivotTable. 
The PivotTable Tools should be available.

Try it: Insert Blank Rows
Go to PivotTable Tools ->Design.
Go to Layout-> Blank Rows.
Select: Insert Blank Line after Each Item
What Do You See? The options for the 
Blank Rows include the following:
Insert Blank Line after Each Item
Remove Blank Line after Each Item

PivotTable Tools ->Design-> Layout->Blank Rows
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Layout: Grand Totals
The Grand Totals can be added to the 
Rows, the Columns, both or neither. 

Before You Begin: Select the PivotTable. 
The PivotTable Tools should be available.

Edit the Field List, please.
Row Labels: Products
Column Labels: Category
Values: Sum of Amount

Try it: Change The Grand Totals Layout
Go to PivotTable Tools ->Design.
Go to Layout-> Grand Totals.
Select: On for Rows and Columns. 

What Do You See? The options for the 
Grand Totals include the following:
Off for Rows and Columns
On for Rows and Columns
On for Rows Only
On for Columns Only

PivotTable Tools ->Design-> Layout-> Grand Totals
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Layout: Filter the Blanks
Well, you have been patiently waiting for 
this lesson for pages and pages. How do 
you hide the blank lines? Here are the 
steps to Filter the Blanks, at last. 

Before You Begin: Select the PivotTable. 
The PivotTable Tools should be available.

Try it: Filter the Blanks
Click on the Row Labels in the PivotTable.
Unselect: (Blank)
Click on the Columns Labels, too.
Unselect: (Blank)
You should see Filters on the Column 
and Row Labels in the PivotTable.

So far so good.

PivotTable Tools ->Design
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PivotTable: Report Layout
There are several Report Layouts that you 
should consider. The goal of any PivotTable is to 
display the data. Depending on the data, some 
of the layouts make sense while others seem 
confusing. 

Before You Begin: Select the PivotTable. The 
PivotTable Tools should be available.

1. Try This: Edit the Field List
Row Labels: Category, then Product
Column Labels: Month
Values: Sum of Amount

Keep going, please...

PivotTable Tools ->Design-> Layout
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PivotTable: Report Layout
2. What Do You See? The PivotTable now 
has subgroups for each Category. The 
monthly sales numbers are calculated and 
displayed in the Columns. 

What Else Do You See? The Column and 
Row Labels have Filters. The (blank) data 
has been filtered.

OK, that's the setup for this PivotTable. Let's 
investigate a few of the Report Layouts. Keep 
going, please...

Memo to Self: These numbers may look odd 
because they are not formatted for currency.

PivotTable Tools ->Design-> Layout->Report Layout
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Report Layout Options
3. Try it: Change the Report 
Layout
Go to PivotTable Tools ->Design.
Go to Layout-> Report Layout.
Select: Show in Outline Form. 

What Do You See? The Report 
Layout options include the 
following:
Show in Compact Form
Show in Outline Form
Show in Tabular Form
Repeat All Item Labels
Do Not Repeat Item Labels

Keep going...

PivotTable Tools ->Design-> Layout->Report Layout
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PivotTable: Styles
A PivotTable can be formatted with Styles. 

Before You Begin: Select the PivotTable. The 
PivotTable Tools should be available.

1. Try it: Format the PivotTable Style
Go to PivotTable Tools ->Design.
Go to PivotTable Styles.
Select: Pivot Style Medium 3. 

What Do You See? The PivotTable Styles 
formatted the Column Headers (Sum of 
Amount, Category, Product)  as well as the 
Row Headers (Corporate, Educational, etc.)

Keep going...

PivotTable Tools ->Design-> PivotTable Styles->Style
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PivotTable Style Options
The PivotTable Style Options offer quick 
formatting choices. Here are the steps. 

2. Try it: Edit the PivotTable Style Options
Select the PivotTable.
Go to PivotTable Tools ->Design.
Go to PivotTable Style Options.
Select: Banded Rows. 

What Do You See? In the example on this 
page, the Rows have been formatted with a 
bottom border.

OK, that about does the discussion on 
PivotTable Design Ribbon.

Memo to Self: If you select Banded 
Columns, the Columns will be outlined with 
vertical borders as well.

PivotTable Tools ->Design-> PivotTable Style Options->Style
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PivotTable: Sort & Filter
A long time ago, in the previous lesson, we 
reviewed the Data Ribbon: Sort, Filter and 
Group. This lesson will finish up with the 
same simple options for a PivotTable: Sort & 
Filter and Group. 

Before You Begin: Select the PivotTable. 
The PivotTable Tools should be available.

1. Try it: Sort & Filter the PivotTable
Select Cell L5.
This is the Subtotal for the Header Row.
Go to PivotTable Tools ->Options.
Go to Sort & Filter.
Click on Sort.

Keep going...

PivotTable Tools ->Options-> Sort & Filter
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PivotTable: Sort & Filter
2. What Do You See?  You will be prompted 
to choose the Sort Options. By default, the 
Values are sorted as follows:
Smallest to Largest
Top to Bottom

Click OK to accept the defaults, please.

What Else Do You See? The Subtotals for 
each group (Corporate, Educational, etc) 
were sorted Smallest to Largest.

Look Again: The Totals for each product are 
NOT sorted Smallest to Largest.

PivotTable Tools ->Options-> Sort & Filter
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PivotTable: Groups
The last example in this lesson is Group. It is 
another way to edit how you display your 
data. Grouping is a way to Show or Hide the 
Rows that you select.

Before You Begin: Select the PivotTable. 
The PivotTable Tools should be available.

Try it: Group the Data
Select Row 5 through Row 19. In this sample 
spreadsheet, this is the sales data for the 
Private and Corporate Sales.

Keep going...

Memo to Self: PivotTables already have 
Groups. The Groups have a plus (+) sign if 
the rows are hidden or a minus (-) sign if the 
rows are displayed. 

PivotTable Tools ->Options-> Group-> Group Selection
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PivotTable: Summary
2. Try It: Group the Data
Go to PivotTable Tools ->Options.
Go to Group-> Group Selection.

What Do You See? When you click on 
Group, you should see an Outline on the left 
side of the spreadsheet. At the top of the 
Outline are two Levels. In the Example on 
this page, we are on Level 2. OK, that will 
do...

This lesson looked at PivotTables and the 
PivotTable Tools. In the next lesson, we will 
review the options for PivotCharts.

OK, OK. Allez allez in free. You done good. 
Go get a cookie!

PivotTable Tools ->Options-> Group-> Group Selection
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Lesson 3: What Happened? (PivotTables)
Before You Begin: Download the sample spreadsheet: Brown Bag Lunch Sales Team.xlsx.

Try This: Do the following steps
1. Open the spreadsheet: Brown Bag Lunch Sales Team.xlsx.
2. Go to Sheet 1. Select Row 1 and remove the Filters.
3. Select Sheet 1 and Insert a PivotTable on a New Worksheet.
4. Use the PivotTable Tools to Show the Field List.
5. Edit the PivotTable Field list as follows:
   Select the Field: Market (It should be placed in the Row Labels, by default).
6. Drag the Field Sales to the Values (It should be placed in the Values as Count of Sales) .

Change Count of Sales to Sum of Sales.
7. Select the Field: Sales Agent (It should be placed in the Row Labels, by default).
8. Move the Field: Sales Agent from the Row Labels to the Column Labels.
9. Format Columns B:G for Accounting.
10. Save this as YOUR NAME What Happened Practice

Practice Activities
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7. Which of the following is an option for 
Grand Totals? (Select all correct answers.)
a. Added to Rows
b. Added to Columns
c. Added to both Rows and Columns
d. Added to neither Rows or Columns
Tip: Advanced Excel, page 106

8. Which of the following are report options?
(Select all correct answers.)
a. Show in Compact form
b. Show in Outline form
c. Show in Tabular form
Tip: Advanced Excel, page 110

9. A Pivot Table can be formatted with Styles
a. True
b. False
Tip: Advanced Excel, page 111

4. The row labels in a Pivot Table are filters. 
a. True
b. False
Tip: Advanced Excel, page 93

5. Which of the following are functions a 
Pivot Table can use? 
(Select all correct answers.)
a. Count Numbers
b. Sum
c. Average
d. Max
e. Min
f. Product
Tip: Advanced Excel, page 97

6. Which of the following are true about 
subtotals in Pivot Tables? 
(Select all correct answers.)
a. Default is to show the subtotal at the top 
of the group
b. Command is Pivot Tables-> Tools-> 
Design> Layout-> Subtotals
c. Subtotals cannot be removed
Tip: Advanced Excel, page 104

1. Which Ribbon has the command for 
creating Pivot Tables?
a. Home
b. Insert
c. Data 
d. Review
Tip: Advanced Excel, page 87

2. Which are the Table Tools Ribbons?
(Select all correct answers.)
a. Options
b. Design
c. View
d. Format
Tip: Advanced Excel, page 89

3. Where do the Pivot Table fields come 
from?
a. Entered in the Pivot Table dialogue box
b. The spreadsheet labels
c. Default in Excel
Tip: Advanced Excel, page 90

Test Yourself

Assesment: Test your skills

Advanced Excel 2010 Page 118 of 298



© 2011 Comma Productions

Excel 2010: Analyzing Data Visually

Advanced Excel Objectives
In this lesson, you will learn how to: 
1. Analyze data visually with a PivotChart
2. Create a PivotChart and Show the Field List
3. Edit the Value Field Settings
4. Filter the data in the PivotChart
5. Edit the Chart Layouts
6. Apply a Chart Style
7. Use Slicers. 

Pivot Charts: What Do You See?
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1. Readings
Read Lesson 4 in the Advanced Excel 
guide, page 119-159.

Project
A spreadsheet that uses PivotCharts to 
present the data in an interactive format.

Downloads
Sales 2010.xlsx
tblCustomers.xml
Brown Bag Sales Data.xlsx

2. Practice
Complete the Practice Activity on page 160.

3. Assessment
Review the Test questions, page 160.

Menu Maps
This lesson shows the PivotChart Tools.
1. PivotChart Tools ->Analyze ->Show/Hide->Field List, page 124
2. PivotChart Tools ->Design ->Data->Switch Row/Column, page 132
3. PivotChart Tools ->Design ->Type-> Change Chart Type, page 135
4. PivotChart Tools ->Design ->Chart Layouts, page 137
5. PivotChart Tools ->Design ->Chart Styles, page 140
6. PivotChart Tools ->Analyze ->Active Field, page 143
7. PivotChart Tools ->Analyze ->Data-> Insert Slicers, page 149
8. PivotChart Tools ->Analyze ->Data-> Refresh, page 153

PivotChart Tools->Design

PivotChart Tools->Analyze

Lesson 4: PivotCharts: What Do You See?
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Start Microsoft Excel
What Do You See? Is 
there a Title Bar that says 
Microsoft Excel? Yes.

Is there a Home Ribbon 
with the Clipboard, Font, 
Alignment and Number 
Groups? Yes.

If your screen looks similar 
to the one on this page, 
then you are ready to get 
started.

Start -> All Programs ->Microsoft Office-> Microsoft Office Excel 2010

Analyzing Data Visually
Most people do not read numbers well. However, they can read a graph and compare the information. A PivotChart offers the 
same flexibility to manipulate the data as a PivotTable. A PivotChart is a graphic representation of the data in the PivotTable. A 
PivotChart, like a PivotTable, is interactive. You can filter and focus on the data until it shows what really happened.
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Before You Begin 
A PivotChart is based on a PivotTable: they go 
together. This lesson begins with a PivotTable. 
After the PivotTable is set up, we will review 
the PivotChart options in Microsoft Excel 
2010.

You can use a spreadsheet that you created or 
download a sample spreadsheet if you wish.

1. Try This: Open a Sample Spreadsheet
Open a sample spreadsheet: Sales2010.xlsx
Go to the Original Data sheet.

What Do You See? This sheet shows the 
product sales for Charlotte' Website. The first 
row is BOLD: it is the Header Row. There are 
many rows of data.

Memo to Self: You do not have to MATCH the 
numbers shown on these pages. It is more 
important that you begin with some data and 
understand the options.

File->Open

Comma Training Page 122

Advanced Excel 2010 Page 122 of 298



Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.4. Apply and manipulate PivotCharts

Create a Pivot Chart
2. Try This: Create a PivotChart
Go to the Original Data spreadsheet.
Select All.
Go to Insert->Tables->PivotTable.
Click on PivotChart.

You will be asked to confirm the location 
of the data and whether you would like to 
place the new PivotChart in a new 
spreadsheet. 

Keep going, please...

Insert-> Tables-> PivotTable->PivotChart
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Hello, Pivot Chart
3. What Do You See? There should be a 
new, blank PivotChart, Chart 1. A blank 
PivotTable should be on the left side of 
the spreadsheet. 

The PivotTable Field List should be on 
the right side.

What Else Do You See? There are four 
PivotChart Tools:
Design
Layout
Format
Analyze

Keep going...

What If You Don't See the PivotTable 
Field List? Please try this:
Go to PivotTable Tools ->Analyze.
Go to Show/Hide-> Field List

PivotChart Tools ->Analyze ->Show/Hide->Field List
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PivotTable Field List
You should see a PivotTable on the left 
side of your spreadsheet but there will not 
be any data in the Chart, yet. 

PivotCharts, like PivotTables, need data. 
We will select the Fields and Count the 
Value with the Field List to create a 
PivotTable Report.

4. Try This: Choose a Field
Go to the PivotTable Field List.
Select: Product.

What Do You See? The PivotTable 
should display each Product. The 
PivotChart has a Product Filter, but the 
Chart is still blank.

Keep going...

PivotChart Tools ->Analyze ->Show/Hide->Field List
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Add a Value 
Look at the bottom of the PivotTable Field 
List. There is only one value: the Product 
is in the Axis Fields. So far so good. 

PivotTables and PivotCharts calculate: 
COUNT, SUM, AVERAGE. This is done 
by adding a field to the Values.

5. Try it: Add a Value
Go to the PivotTable Field List.
Select: Amount.
Drag the Amount to the Values.

What Do You See? The Value was 
displayed as Count of Amount in the 
PivotTable as well as the PivotChart.

Keep going...

PivotChart Tools ->Analyze ->Show/Hide->Field List
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Edit the Value Field
By default, the Value was displayed as 
Count of Amount. In this example, 
Amount  is money: how much was sold? 
This data would make more sense if the 
Value was displayed as the Sum of the 
Amount. 

6. Try it: Edit the Value Field
Go to the PivotTable Field List.
Go to the Values.
Select: Count of Amount.
Click on Value Field Settings...

Keep going...

Memo to Self: The Field options include:
Move to Report Filter
Move to Axis Fields (Categories)
Move to Legend Fields (Series)
Hide Value Field Buttons on Chart
Hide All Field Buttons on Chart
Remove Field
Value Field Settings...

PivotChart Tools ->Analyze ->Show/Hide->Field List
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Value Field Settings 
You can choose the type of calculation 
you wish to use to summarize and display 
the data in the PivotTable and PivotChart.

7. Try it: Edit the Value Field Settings
Go to the Summary list.
Choose: Sum.

What Do You See? The Custom Name 
should be Sum of Amount, now.

Please click OK and keep going...

PivotChart Tools ->Analyze ->Show/Hide->Field List
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Sum of Amount
8. Try it: Format the Data
Sum of Amount is money-sales data. 
Select Column B.
Go to Home->Number.
Click on Currency.

Select Column B, again.
Go to Home->Number.
Click on Decrease Decimals twice.

Try This, Too: Save the PivotTable
Go to File->Save As.
Name the workbook: MyName PivotCharts.
Save. Save. Save.

Very good.

Home ->Number
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Add Another Field
At this point, our PivotTable has one field 
in the Axis (the Category) and the Sum of 
Amount for the Value. When you add 
another field to the PivotTable, you add 
another layer of complexity to your chart.

This lesson will add a field to the Legend, 
(the Series). This will create a Cross-Tab 
PivotTable. It will also change how the 
data is displayed in the PivotChart.

Before You Begin: Select the PivotChart. 
The PivotChart Tools should be available.

1. Try it: Add Another Field
Go to PivotChart Tools ->Analyze.
Go to Show/Hide->Field List
Select: Category
Drag Category to the Legend Fields.

Keep going...

PivotChart Tools ->Analyze ->Show/Hide->Field List
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PivotChart Displays 
2. What Do You See? The PivotTable 
has the following Column Labels: 
Corporate, Educational, Government, and 
Private. There is a Filter on the Column 
Labels as well as on the Row Labels that 
list the products sold.

What Else Do You See? The PivotChart 
may be displayed on top of the 
PivotTable. In the example on this page, 
the PivotChart was moved down and 
resized wider to see the columns better.

Keep going...

PivotChart Tools ->Design
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PivotChart Design 
The purpose of creating a PivotTable or 
PivotChart is to analyze the data visually. 
Sometimes the data may be easier to 
understand if the Rows and Columns are 
switched. By definition, this is how you 
"pivot" the table.

Before You Begin: Select the PivotChart. 
The PivotChart Tools should be available.

3. Try It: Switch Rows and Columns
Go to PivotChart Tools ->Design.
Go to Data->Switch Row/Column.

What Do You See? The data has been 
switched: the products are displayed in 
the Columns and the Categories are 
shown in the Rows. Keep going...!

PivotChart Tools ->Design ->Data->Switch Row/Column
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Data: Switch Row/Column 
4. What Else Do You See? When you switched the Rows and Columns, the PivotChart was updated as well. This PivotChart uses 
color and position to display the sales data. Each product listed on the Axis can have up to four columns of data. The Sum of Amount 
is displayed on the left, formatted as currency.  What Do You Think? Can you read and understand this PivotChart? Keep going...!

PivotChart Tools ->Design ->Data->Switch Row/Column
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Filter the Data 
Filters let you focus on key information. 
Say you wanted to analyze just the 
three new products. Here are the steps.

Before You Begin: Select the 
PivotChart or PivotTable, please.

5. Try This: Filter the Data
Go to the PivotTable.
Click on the Column Labels and select:
Edible Fruit
Fruit and Veggies
Hot Platter

What Do You See, Now? The 
Computer Mama sez it is easier to 
compare a few products than the dozen 
or so products that were displayed on 
the previous page.

Memo to Self: This step is easy if you 
click off "Select All," first,

PivotChart Tools ->Design
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Design: Change Chart Type 
The following pages will go through the 
options on the PivotChart Design Ribbon. 

Our discussion will include how to edit the 
Chart Type, Layouts and Styles. We will also 
Move the PivotChart to a different 
spreadsheet.

Before You Begin: Select the PivotChart.

1. Try it: Change the Chart Type
Go to PivotChart Tools ->Design->Type.
Click on: Change Chart Type.
There should be a gallery of Chart Types: 
Column, Line, Pie, Bar, etc.

Try This, Too: Select a New Chart Type
Go to the Column category.
Select: Stacked Column. 

Click OK. Keep going...

PivotChart Tools ->Design ->Type-> Change Chart Type
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Chart Type Options 
2. What Do You See? The PivotChart 
should update to the new Chart Type. 

The Stacked Column format 
simplified the PivotChart. Instead of 
three columns for each customer 
category (Corporate, Educational, etc) 
there is only one that shows how the 
Products add up together. Keep 
going...

PivotChart Tools ->Design ->Type-> Change Chart Type
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Design: Chart Layouts 
Microsoft Excel 2010 has a library of 
Chart Layouts: templates that format the 
Title, Legend, Data Tables and Axis 
Labels. Here are the steps.

Before You Begin: Select the PivotChart. 
The PivotChart Tools should be available.

1. Try it: Change the Chart Layout
Go to PivotChart Tools ->Design.
Click on: Chart Layouts.

There should be a gallery of Chart 
Layouts. Select: Layout1.
Keep going...

PivotChart Tools ->Design ->Chart Layouts
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Chart Layout Options 
2. What Do You See? The PivotChart 
Layout formatted the Stacked 
Columns. It is easier to see the data 
bands on the wider columns.

Try This, Too: Edit the Chart Title
Double Click the Chart Title.
Type: New Product Sales.

Very good. That was Chart Type and 
Chart Layouts. Keep going...!

PivotChart Tools ->Design ->Chart Layouts
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Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.4. Apply and manipulate PivotCharts: Edit the Chart Layout

PivotChart: Layout Review 
The Chart Layouts offer several pre-
formatted templates. Each object in a 
PivotChart can be edited by hand as well. 

We covered Chart Design and Layout 
extensively in the Beginning Guide to 
Excel 2010. The PivotChart Layout Tools 
are the same. 

PivotChart Tools ->Layout include:
Current Selection
Insert (Picture, Shapes, Text Box)
Labels
Axes
Background
Analysis
Properties

Our discussion continues...keep going.

PivotChart Tools ->Layout
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Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.4. Apply and manipulate PivotCharts: Styles

Design: Chart Styles 
The Chart Styles format the Data 
(columns or pie pieces), Shape Fill and 
Shape Outline, Background and Axis. 

Before You Begin: Select the PivotChart. 
The PivotChart Tools should be available.

Try it: Select a Chart Style
Go to PivotChart Tools ->Design.
Go to Chart Styles.

There should be a gallery of Chart Styles. 
Choose one that you like.

That works. 

PivotChart Tools ->Design ->Chart Styles
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Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.4. Apply and manipulate PivotCharts: Chart Styles

Design: Move Chart 
By default, a PivotChart is usually created 
on the same sheet that has the 
PivotTable. You can Move a PivotChart to 
a different sheet if you wish. Here are the 
steps.

Before You Begin: Select the PivotChart. 
The PivotChart Tools should be available.

1. Try it: Move a PivotChart
Go to PivotChart Tools ->Design.
Go to Move Chart-> Location.

2. What Do You See? You will be asked 
where you want to move the chart. You 
can move the chart to a New Sheet. You 
can also place the chart as an Object in
an existing sheet. 

No surprises here. Click CANCEL and 
keep going, please. 

PivotChart Tools ->Design ->Move Chart-> Location
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Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.4. Apply and manipulate PivotCharts: Analyze

Analysis Tools 
One of the newest tools in Excel is the 
Slicer. The Slicer can be found on the 
Analyze Ribbon as part of the PivotChart 
Tools. We'll start with the options for the 
Active Field and then work with the Slicer.

Before You Begin: Select the PivotChart. 
The PivotChart Tools should be available.

1. Try it: Review the Analyze Tools
The Analyze Tools include:
Active Field
Data
and Show/Hide.

Keep going...!

PivotChart Tools ->Analyze 
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Exam 77-888: Microsoft Excel Expert 2010
3. Presenting Data Visually
3.4. Apply and manipulate PivotCharts: Analyze

Analysis: Active Field
Start with the simple tools: You can select 
any field and show additional data.  The field 
that you select is called the Active Field. 

You can use the Active Field to Expand 
(show) or Collapse (hide) more details. Say 
you wanted to see who sold the Fruit and 
Veggie products. Here are the steps.

2. Try it: Select a Field in the PivotChart
Click on the PivotChart Legend.
Click on a Field: Fruit and Veggies.
Keep going...

Memo to Self: Expanding or Collapsing a 
field is easy. Selecting the correct place on 
the PivotChart can be frustrating! 

What should you look for?  When you select 
a Field, the Analysis Tools will display this 
field as well as any other that you have 
enhanced. 

PivotChart Tools ->Analyze ->Active Field
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3. Presenting Data Visually
3.4. Apply and manipulate PivotCharts: Analyze Data with the Active Field

Analysis: Use the Active Field 
3. Try it: Expand the Active Field
Go to PivotChart Tools->Analyze.
Go to Active Field.
Click on Expand Entire Field.

What Do You See? You will be prompted to 
choose which data you would like to show.

Our question was: Who sold what? If you choose 
Sales Rep, the PivotChart will display the names 
of the people who sold products.

Try this, Too: Select a Field for the Detail
Show Detail: Sales Rep.

Please click OK and keep going...

PivotChart Tools ->Analyze ->Active Field
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3. Presenting Data Visually
3.4. Apply and manipulate PivotCharts: Analyze Data with the Active Field

Expand Active Field 
4. What Do You See? There should 
be a new filter on the PivotChart 
legend.

The example on this page shows 
which sales rep sold what products.

This is an interactive PivotChart. You 
can filter the information by Category 
(Corporate, Educational, Government, 
Private), Product and Sales Rep.

But wait, there really is more....

PivotChart Tools ->Analyze ->Active Field
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3. Presenting Data Visually
3.4. Apply and manipulate PivotCharts

PivotTable: Analyze 
5. What Else Do You See? When you edit 
the PivotChart, you are modifying the 
PivotTable as well. 

The Column Labels show new subtotals for 
each product. The subtotals calculate how 
much product each sales rep sold.

The PivotTable was formatted automatically 
with banded columns. 

Rename this spreadsheet PivotTable by 
Category and Save your work.

Memo to Self: As you work with the tools 
you should keep in mind the purpose of this 
chart. What story are you trying to convey in 
a quick, effective visualization? Would it be 
easier to see the data as a PivotTable? 

Keep it simple and easy to read.

PivotChart Tools ->Analyze
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3. Presenting Data Visually
3.4. Apply and manipulate PivotCharts

Analyze: Slicers 
Slicers are a new way to filter the data in 
PivotTables and PivotCharts. The 
previous pages walked you through the 
steps of building a complex PivotChart 
with multiple filters. It is effective, but 
rather clumsy to work with.

The next couple of pages begin with a 
new PivotChart and demonstrates how 
you can use the Slicers. 

1. Try it: Create a new PivotChart
Go to the Original Data spreadsheet.
Select All.
Go to Insert-> Table-> PivotTable.
Click on PivotChart.

You will be asked to confirm the location 
of the data and whether you would like to 
place the new PivotChart in a new 
worksheet. Click OK. Keep going...

Insert-> Table-> PivotTable->PivotChart
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3. Presenting Data Visually
3.4. Apply and manipulate PivotCharts: Add a Value

Modify the PivotChart
2. Try This: Choose a Field
Go to the PivotTable Field List.
Select: Month.

Try This, Too: Add a Value
Go to the PivotTable Field List.
Select: Amount.
Drag the Amount to the Values.
You should see Count of Amount.

And This: Edit the Value Field Settings
Go to the Values.
Select: Count of Amount.
Click on Value Field Settings...
Summarize Field Value by: SUM.

Keep going...

PivotChart Tools ->Analyze ->Show/Hide->Field List
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3.4. Apply and manipulate PivotCharts: Analyze data with Slicers

Use Slicers to Filter the Data
Before You Begin: Click on the PivotChart. 
The PivotChart Tools should be available.

1. Try it: Insert Slicers
Go to PivotChart Tools ->Analyze-> Data.
Click on Insert Slicer.

What Do You See? You will be prompted to 
select the Fields you want to include.
Select the following fields:
Category
Product

Please click OK. Keep going...

PivotChart Tools ->Analyze ->Data-> Insert Slicers
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3.4. Apply and manipulate PivotCharts: Analyze data with Slicers

Hello, Slicers! 
2. What Do You See? At the top of the 
Slicers is a Header. Next to the name on the 
Header is a Filter.

Below the Header you should see a list of 
Items. You can use the Items to filter your 
data. To the right of the Item list, on the scroll 
bar, is the Clear Filter button. Look for three 
lines stacked like a Slicer. 

So, How Do They Work? By default, new 
Slicers display all of the data. If you click on a 
Item in the Slicer-say Breakfast Buffet-the 
PivotTable and PivotChart will show only the 
data for Breakfast Platters.

Memo to Self: You can select more than one 
Item by holding the CONTROL key on your 
keyboard as you click on the Items. 

PivotChart Tools ->Analyze ->Data ->Insert Slicers
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Slicer Tools 
Slicers, like Charts, Shapes and Pictures, 
have their own set of Tools.

The Slicer Tools include:
Slice
Slice Style
Arrange
Buttons
Size

Before You Begin: Click on the Slicer. 
The Slicer Tools should be available.

3. Try it: Format the Slicer
Go to Slicer Tools ->Options.
Select a Slicer Style: Dark 6

What Else Do You See? You can use the 
options in the Arrange group to bring a 
Slice in front or back if you wish.

Rename this spreadsheet Slicers and 
Save your work.

Slicer Tools ->Options-> Slicer Styles
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Analyze: Refresh 
The beauty of working with PivotTables 
and PivotCharts is how easy it is to 
update the information in the Table or 
Chart.

Before You Begin: Go to the Slicer 
spreadsheet. Select the PivotChart. The 
PivotChart Tools should be available. 
Please remove all Filters on the Slicers.

1. Try it: Add More Data
Go to the Monthly Sales sheet.
Select the last two Rows: Row 68 and 69.
Go to Home->Copy.
Select Cell A70.
Go to Home->Paste.

The data in this example has been 
updated. There are now two more 
Breakfast Buffets in the records.

Did the PivotTable update? Let's find 
out...

PivotChart Tools ->Analyze ->Data
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3.4. Apply and manipulate PivotCharts

Refresh the PivotChart 
2. First, Review the PivotChart
Go to the Slicer spreadsheet. 
Did the PivotTable or PivotChart update? 
Maybe,..maybe not. What if it didn't?

OK, Try This: Refresh the Data.
Click on the PivotChart to select it. 
Go to PivotChart Tools ->Analyze ->Data.
Click on Refresh.

What Do You See? The data for the Breakfast 
Buffet has updated. The sales subtotal has been 
updated to include the two, new sales.

PivotChart Tools ->Analyze ->Data-> Refresh
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Analyze External Data in Excel 
You can use PivotTables, PivotCharts, and
Slicers to analyze information outside of a 
spreadsheet. The External Data can come from 
Microsoft Access, from the Internet, or from a 
server or mainframe. Microsoft Excel can also 
connect to a SharePoint server.

The following pages will show how to connect a 
PivotTable to a mighty Microsoft Access 
database that has a table of customers, 
tblCustomers.

1. Try This: Insert a PivotChart 
Open the a new, blank spreadsheet.
Go to Insert-> Table-> PivotTable.
Click on PivotChart.
Go to Use an external data source.
Click on Choose Connection.
Keep going...

Memo to Self: This lesson uses a sample 
Microsoft  Access database. If you are not 
familiar with Access, or if you do not have 
Access on your computer, you may not be able 
to practice these steps. That is OK. 

Insert-> Table->PivotTable-> PivotChart
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Connect to Other Data 
When you click on Choose Connection, 
you will see a list of data connections. By 
default the list shows All Connections. 

The Existing Connections can include:
All Connections
Connections files in the Workbook
Connection files on the Network
Connection files on this computer

If you don't see you data source listed, 
you can Browse for More.

2. Try it: Browse for More
At the Existing Connections window.
Click on Browse for More.
Keep going...!

Insert-> Table-> PivotChart->Use an External Data Source
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Select the External Data 
Microsoft Access databases have Tables 
as well as Queries. When you connect to 
an Access database, you will be prompted 
to Select a Table or Query.

3. Try it: Select a Table of Query
Select Table: tblCustomers.
Keep going...!

Memo to Self: A Query is a way to use 
formulas and filters to present the data in 
your tables.

Insert-> Table-> PivotChart->Use an External Data Source
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Analyze the External Data 
4. Create a PivotTable with External Data
The following steps add fields and values to 
create a PivotChart using the Access table. 

Try This: Choose a Field
Go to the PivotTable Field List.
Select: City.

Try This, Too: Add a Value
Go to the PivotTable Field List.
Select: CustomerID.
Drag the CustomerID to the Values.
You should see Count of CustomerID.

What if it says Sum of CustomerID?
Click on Sum of CustomerID.
Click on Value Field Settings.
Select: COUNT

And Try This: Change the Chart Style
Go to PivotChart Tools ->Design.
Choose a Chart Style.

This works. Keep going...

PivotChart Tools ->Design ->Chart Styles
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Refresh the Data 
Data is dynamic. Say business is good 
and a lot of new customers were added 
today. You can use the PivotTable or 
PivotChart Tools to Refresh the data.

5. Try it: Refresh the Data
Click on the PivotTable Grand Total. 
The PivotTable Tools should be available.
Go to PivotTable Tools ->Data.
Click on Refresh.

The options include:
Refresh
Refresh All
Refresh Status
Cancel Refresh

You can also manage the Connection 
Properties if you wish.

Very good. 
You do NOT have to save this example. 

PivotTable Tools ->Data ->Refresh
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Summary 
This discussion began by introducing the 
methods and options for displaying your 
data in a PivotChart.

There were several new Toolbars used in 
these pages. However, the PivotChart 
Design, Layout and Format Ribbons are 
very similar to the Table Ribbons we 
worked with in an earlier spreadsheet.

The new Slicer filters for PivotTables and 
PivotCharts works very well. That's one 
the Computer Mama will use at work.

Well, that was a loooong discussion.
You get a cookie.
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5. When the rows and columns of a Pivot 
Table are switched the Chart is switched 
as well.
a. True
b. False
Tip: Advanced Excel, page 133

6. Which of the following are Chart types 
that can be applied to a Pivot Chart?
(Select all correct answers.)
a. Column
b. Line
c. Pie
d. Bar
Tip: Advanced Excel, page 135

7. Pivot Charts have Styles
a. True
b. False
Tip: Advanced Excel, page 140

8. A chart cannot be moved to a new 
spreadsheet after it’s been created.
a. True
b. False
Tip: Advanced Excel, page 141

1. Which Ribbon has the Pivot Chart 
command?
a. Home
b. Insert
c. Data
d. View
Tip: Advanced Excel, page 123

2. Which of the following are Pivot Chart 
Tools ribbons?
a. Design
b. Layout
c. Format
d. Analyze
Tip: Advanced Excel, page 124

3. When inserting a new blank Pivot 
Chart, a Pivot Table is also created
a. True
b. False
Tip: Advanced Excel, page 125

4. Rows in a Pivot Table cannot be 
formatted with currency.
a. True
b. False
Tip: Advanced Excel, page 129

Lesson 4: What Did You See? 
(Formatting PivotCharts)
Before You Begin: Download the sample spreadsheet: 
Brown Bag Sales Data.xlsx.

Try This: Do the following steps 
1. Open the spreadsheet: Brown Bag Sales Data.xlsx..
2. Select Sheet 1and Insert a PivotChart on a New Worksheet.
3. Use the PivotChart Tools to Show the Field List
4. Edit the PivotTable Field List as follows:
   Axis Field: Product
   Values: Sum of Amount
5. Use the PivotChart Tool to the Chart Design:
   Change Chart Type: 3D Pie
   Chart Style: Style  6
6. Filter the Row Labels to show Breakfast Sandwiches, Coffee 
and Tea, and Fruit and Veggie.
7. Use the PivotChart Tools to edit the Chart Layout:
  Legend: None
  Data Labels: Outside End
  3-D Rotation:  edit X to be 50
8. Save this a YOUR NAME What Did You See Practice. 

Test YourselfPractice

Assesment: Test your skills
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Excel 2010: Sharing and Collaboration

Advanced Excel Objectives
In this lesson, you will learn how to: 
1. Enter data and fill a series
2. Enter data in a reference list
3. Create a drop-down list
4. Identify options for Data Integrity and Validation
5. Install the Developer's Ribbon
6. Create a Control with Visual Basic for Applications

Form Design: Working Overtime
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1. Readings
Read Lesson 5 in the Advanced Excel 
guide, page 161-193.

Project
This lesson shows how to create and 
modify forms, enter data with Combo Boxes 
and form controls, ensure data integrity 
using data validation.

Downloads
Time Sheet 2010.xlsx (Complete)

2. Practice
Review the Practice Activity on page 194.

3. Assessment
Review the Test questions, page 194.

Menu Maps
From the Data Ribbon.
1. Data ->Data Tools-> Data Validation, page 171

From the Formulas Ribbon.
2. Formulas ->Defined Names-> Define Name, page 175

From the Developers Ribbon
3. Developer ->Controls->Insert->Combo Box, page 187
4. Developer ->Controls ->Properties, page 189

Data Ribbon

Developer Ribbon

Lesson 5 Form Design: Working Overtime
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Start Microsoft Excel
What Do You See? Is there a 
Title Bar that says Microsoft 
Excel? Yes.

Is there a Home Ribbon with 
the Clipboard, Font, 
Alignment and Number 
Groups? Yes.

If your screen looks similar to 
the one on this page, then you 
are ready to get started.

Start -> All Programs ->Microsoft Office-> Microsoft Office Excel 2010

Creating Forms in Excel 
Time is money. The Computer Mama gets paid by the hour, so she has to keep track of how long it takes to 
complete each task. The technical term is billable hours. Suppose you work for the same Accounts every week. 
What if you could just choose the Account from a list? Choosing the answer from a list has two benefits: the data 
entry is faster, and it is spelled correctly. This lesson shows how a little time invested into creating a form can save 
time again and gather accurate information.
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Begin with the Labels 
There are three parts to a spreadsheet: 
labels, data, and formulas. Let’s begin with 
the labels.

Before You Begin: Open a new, blank 
spreadsheet in Excel.

1. Try This: Enter the Labels
In Cell A1 type: Monday
Use the AutoFill Handle to fill in the series.
In Cell G1 type: Total

If these are labels (and they are):
Select Row 1.
Go to Home->Font->Bold.

Try This, Too: Format the Column Width
Select Columns A:G
Go to Home->Cells->Format.
Click on Column Width.
Enter the width: 12.

So far so good. Keep going...

Home->Font->Bold

Monday, Monday! Can’t Trust That Day. 
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Calculate the Hours 
We need an equation to add up all of our 
hours. All good equations start with “=.”

2. Try it: Calculate the Sum
In Cell G2 type:  =SUM(A2:F2)

Try This, As Well: Verify Your Work 
Say you worked 8 hours on Monday, 
Wednesday and Friday. 
In Cell A2, C2 and E2 type: 8
Does the Sum equal 24? 

Keep going...

Home ->Edit ->Sum
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Exam 77-882: Microsoft Excel 2010 Core
2. Creating Cell Data
2.2. Apply AutoFill

AutoFill the Formula 
3. Try This: AutoFill the Total
Select Cell G2, the one with the formula 
for the Total. Use the AutoFill handle to 
copy the formula down to Row 12. 

Keep going, please...

Home ->Edit ->Sum
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Exam 77-882: Microsoft Excel 2010 Core
3. Formatting Cells and Worksheets
3.1. Apply and modify cell formats

Format the Spreadsheet 
4. Try it: Format as Table
Select Cells A1:G12.
Go to Home->Styles->Format as Table.
Click on Table Style Light 16.

And Try This: Format the Rows
Select Cells A1:G12.
Go to Home->Cells->Format..
Click on Row Height.
When you are prompted type: 20.

What Do You See? The Cell formatting 
makes it easy to pick the right Row. The 
Row Height was increased to make the 
Rows big enough to write in by hand if 
someone uses this form as a print out.

Keep going...

Home ->Styles->Format as Table
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Exam 77-882: Microsoft Excel 2010 Core
5. Applying Formulas and Functions
5.1. Create formulas

AutoSum the Hours 
This timesheet will calculate the daily total. 
For example, how many hours did you work 
on Monday?

5. Try it: AutoSum the Data
Select Cell A13.
Go to Formulas ->AutoSum ->Sum.

What Do You See? The formula in Cell A13 
is =SUBTOTAL(109,[Monday])

What Else Do You See? The AutoCorrect 
options allows you to select the following:
Place Formula in Table Total Row
Place Formula Inside Table
Place Formula Below Table.

Pick Place Formula in Table Total Row.
Keep going...!

Memo to Self: You may have been 
expecting a formula that looked like this:
=SUM(A2:A12).
This is a Table, so the function is different.

Formulas ->AutoSum ->Sum
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5. Applying Formulas and Functions
5.1. Create formulas

AutoFill the Formula
You can use AutoFill to copy the formula 
to all of the Cells in Row 13 from Column 
A through Column G.

6. Try it: AutoFill the Formula
Select Cell A13.
Use the AutoFill handle to copy the 
formula to B13 through G13.

What Do You See? The Total Row in a 
Table has options. When you click on a 
formula in the Total Row, you can choose 
which function you would like to use.

Keep going...

Formulas ->AutoSum ->Sum
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Exam 77-882: Microsoft Excel 2010 Core
4. Managing Worksheets and Workbooks
4.1. Create and format worksheets

Insert Columns
Suppose we work for more than one 
company. How can we show that? 

7. Try This: Add a Column
Select Column A. 
Go to Home->Cells->Insert.
Click on Insert Sheet Columns. 
There will be a new, blank Column A. 
Click on Cell A1 and type: Accounts.

Try This, Too: Labels Should Be Bold 
Select Row 1 and make the labels bold by 
going to Home->Font->Bold.

And Try This: Labels Should Fit
When you insert a Column, you may see the 
Format Painter. The options include:
Format Same as Left
Format Same as Right
Clear Formatting.

Click on Format Same as Right 
Rename this spreadsheet: Timesheet.
Keep going, please.

Home ->Cells ->Insert-> Insert Sheet Columns
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Exam 77-888: Microsoft Excel Expert 2010
2. Applying Formulas and Functions
2.4. Apply functions in formulas: Data Validation

Data Validation 
Data Validation is used to ensure data 
integrity. Data Integrity means the user 
typed in the value that belongs to the cell. 

Data Validation compares what the user 
types and alerts them if they typed something 
that did not match.

For example: Did your users enter today's 
date instead of number of hours in the time 
sheet? If they make a mistake Data 
Validation would alert them with an error 
message. 

Better yet, the message would give them 
enough information to correct their mistake 
and try again.

1. Try it: Practice with Data Validation
Select Cell B2. 
Delete any sample data, please.
Go to Data ->Data Tools-> Data Validation.

Keep going...

Data ->Data Tools-> Data Validation
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Exam 77-888: Microsoft Excel Expert 2010
2. Applying Formulas and Functions
2.4. Apply functions in formulas: Data Validation Settings

Data Validation: Settings 
2. What Do You See? Data Validation 
has three tabs: Settings, Input Message 
and Error Alert. 

What Else Do You See? By default, 
Microsoft Excel accepts Any value: you 
can enter an equation or type the words to 
Good Night, Moon. 

Keep going...

Data ->Data Tools-> Data Validation
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Exam 77-888: Microsoft Excel Expert 2010
2. Applying Formulas and Functions
2.4. Apply functions in formulas: Data Validation Settings

Data Validation: Settings 
Pick a Number from 1 to 10
Here is an example that allows a Whole 
Number between 0 and 11.

3. Try it: Enter the Validation criteria
Allow: Whole Number
Data: between
Minimum: 0 (that's a zero)
Maximum: 11

Click OK and keep going...

Data ->Data Tools-> Data Validation
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Exam 77-888: Microsoft Excel Expert 2010
2. Applying Formulas and Functions
2.4. Apply functions in formulas: Data Validation

Test the Settings 
4. Try it: Enter an invalid number
Go to Cell B2.
Type: 12
Click Tab or Enter to leave the cell.

What Do You See? Well, it's a Microsoft 
error message: completely accurate but not 
exactly clear. 

There are three error options:
Retry: leaves the wrong number in Cell B2.
Cancel: Clears the wrong number in Cell B2.
Help: Opens a Help article.

Say this is the first time you saw this error 
message. How would you know what each 
button meant? Keep that in mind...

Click CANCEL. Cell B2 should be empty.

So far, so good. Let's investigate a different 
validation criteria, please. 

Data ->Data Tools-> Data Validation
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Exam 77-882: Microsoft Excel 2010 Core
5. Applying Formulas and Functions
5.5. Apply named ranges in formulas

Create a Drop Down List 
You can use Data Validation to create a Drop 
Down List that looks up the values in a table. This 
Timesheet will lookup a list of clients in a Table. The 
clients will be names of cities in this example.

There are 3 steps to creating a Drop Down List
1. Create the reference table
2. Name the reference table
3. Use the Named Range in the Validation Settings.

1. Try This: Create the Reference Table
Go to a blank spreadsheet. Enter the following:
In Cell A1 type: Ann Arbor
In Cell A2 type: Chicago
In Cell A3 type: Detroit
In Cell A4 type: Flint
In Cell A5 type: Brighton
In Cell A6 type: Boston
In Cell A7 type: Houston
In Cell A8 type: Denver

2. Try This, Too: Name the Reference Table
Select A1:A8.
Name the Range: Clients.

Formulas ->Defined Names-> Define Name
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Exam 77-888: Microsoft Excel Expert 2010
2. Applying Formulas and Functions
2.4. Apply functions in formulas: Data Validation Settings

Data Validation: Settings 
Before You Begin: Rename the Sheet
Double-click the tab.
Rename the sheet: Accounts.

3. Try This: Create a Drop Down List
Go to the Time Sheet.
Select Cell A2.
Go to Data ->Data Tools-> Data Validation.
Allow: List
Source: =Clients

Keep going...

Memo to Self: All equations begin with 
equals. (=). Clients is the Name of the 
reference table.

Data ->Data Tools-> Data Validation
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Exam 77-888: Microsoft Excel Expert 2010
2. Applying Formulas and Functions
2.4. Apply functions in formulas: Data Validation Input Message

Data Validation: Input Message 
Who wants to be successful? Yes, anyone who 
fills out your form hopes to complete the task 
quickly and correctly. So, use the Input Message 
to teach them how to fill in the blanks. Here are 
the steps: 

4. Try This: Edit the Input Message
Go to the Input Message Tab.
Please type the following:
Title: Our Clients
Input Message: Select a client form the list.

Keep going...!

Data ->Data Tools-> Data Validation
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Exam 77-888: Microsoft Excel Expert 2010
2. Applying Formulas and Functions
2.4. Apply functions in formulas: Data Validation Error Alert

Data Validation: Error Alert
The Error Alert prompts people to fill in the 
right data. The Error Alert has a Title, Error 
message and a Style.

5. Try it: Edit the Error Alert
Go to the Error Alert Tab.
Select the Style: Information
Title: Click CANCEL and try again
Error Message: Select a client from the list.

Click OK and keep going...

Memo to Self: There are three Styles of 
Error Alerts: Stop, Warning, or Information. 
Each one has a different symbol and a 
different sound. Something as simple as 
picking a name from a list is Information, not 
a Critical Stop with every bell and whistle 
firing....really.

The Computer Mama has a theory that the 
more you help your users, instead of scaring 
the wits out of them, the more they will be 
inclined to use your forms.

Data ->Data Tools-> Data Validation
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Exam 77-888: Microsoft Excel Expert 2010
2. Applying Formulas and Functions
2.4. Apply functions in formulas: Data Validation

Data Validation: Try it 
What Do You See? The Input Message 
has a title and little bit of help.

What Else Do You See? Cell A2 has a 
Drop-Down list.

6. Try it: Select a Name from the List
Go to Cell A2.
Select Brighton from the list.
Click TAB on the keyboard to go to B2.

Very good. Keep going...!

What If It Doesn't Work? There are two 
parts to testing a Drop Down list. 
1. Can you see the list?
2. Can you click on a list on the list?

If you cannot see the list, then the name 
for your reference list is spelled wrong or 
you forgot to include the equals (=) sign in 
your Settings. 

Data ->Data Tools-> Data Validation

Comma Training Page 179

Advanced Excel 2010 Page 179 of 298



Exam 77-888: Microsoft Excel Expert 2010
2. Applying Formulas and Functions
2.4. Apply functions in formulas: Data Validation

Data Validation: Errors
What happens if you type a name that is NOT 
on the list...as many users do?

7. Try it: Type the Wrong Name
Go to Cell A2.
Type: Lansing.
Click TAB on your keyboard to go to B2.

What Do You See? If the data does not 
match--hence it isn't valid--then you will be 
prompted with your Error Alert.

What Did You Hear? Did you hear a little 
chime when you tabbed out of Cell A2?

What Are the Options? If you click OK you 
will return to Cell A2, but leaves the wrong 
name there. If you click CANCEL then you 
will return to Cell A2 and it will be empty.

Click CANCEL, please.

Data ->Data Tools-> Data Validation
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Exam 77-888: Microsoft Excel Expert 2010
2. Applying Formulas and Functions
2.4. Apply functions in formulas: Data Validation

Data Validation: Summary 
You can Autofill the Data Validation--
including the Input Message and Error 
Alert--to the rest of the cells in Column A.

8. Try it: Autofill the Data Validation
Select Cell A2. 
Use the Autofill handle to copy and paste 
the Data Validation from A2:A12

Do This, Too: Save Your Work
Go to File->Save.
File Name: Your Name Time Sheet

You done good.

Data ->Data Tools-> Data Validation
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Introduction to Form Design
Microsoft Excel has a more sophisticated set 
of Form options on the Developer Toolbar. 
This lesson will introduce the Developer 
Tools and Form Controls. 

1. Before You Begin: Make a Copy
Right-click the Timesheet tab.
Left-click Move or Copy.
Check: Create a Copy

What Do You See? There should be a new 
spreadsheet named Timesheet (2).

Keep going...
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Exam 77-888: Microsoft Excel Expert 2010
2. Applying Formulas and Functions
2.4. Apply functions in formulas: Data Validation

Still Before You Begin 
The spreadsheet that we just copied has cells 
formatted with Data Validation. Here are the 
steps to remove those settings.

2. Try it: Change the Validation Criteria
Go to Timesheet (2).
Select Cells A2:A12.
Go to Data ->Data Tools-> Data Validation.
Click on Clear All.

Click OK. Keep going...

Data ->Data Tools-> Data Validation
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Exam 77-882: Microsoft Excel 2010 Core
1. Managing the Worksheet Environment
1.3. Personalize environment by using Backstage

Find the Developer Tools 
By default, the Developer Toolbar is not 
visible. You can make the Developer 
Tools available in the Excel Options.

3. Try it: Edit the Options
Go to File. This is the Backstage View.
Click on Options. Keep going...!

File ->Options
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Exam 77-882: Microsoft Excel 2010 Core
1. Managing the Worksheet Environment
1.3. Personalize environment by using Backstage

Customize the Ribbons 
You can choose which Commands and 
Ribbons you wish to display in Excel. 

The Main Tabs include:
Home
Insert
Page Layout
Formulas
Data
Review
View.

4. Try it: Customize the Ribbon
Go to Customize Ribbon.
Go to the right column, the Main Tabs.
Check: Developer
Click OK and keep going...

File ->Options->Customize Ribbon

Memo to Self: By Default, the Developer Tab 
is not visible. You need to click on the check 
box to make it available.
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Exam 77-888: Microsoft Excel Expert 2010
4. Working with Macros and Forms
4.2. Insert and manipulate form controls

The Developer Tab 
The Developer Tab is placed at the far 
right of the Ribbons.

5. Try it: Review the Developer Tools
The Developer groups include:
Code
Add-Ins
Controls
XML
Modify
Very good. Let's build a form.

Developer
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Exam 77-888: Microsoft Excel Expert 2010
4. Working with Macros and Forms
4.2. Insert and manipulate form controls

Add a Combo Box 
Microsoft Excel has several methods for 
enabling the user to select an item from a 
list. Data Validation can be used to create 
an In-Cell Drop Down. Visual Basic 
programming is another method.

1. Try it: Add a Combo Box
Go to Timesheet (2)
Select Cell A2.
Go to Developer ->Controls.
Click on Insert->Combo Box.

Keep going, please.

Developer ->Controls->Insert->Combo Box
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Exam 77-888: Microsoft Excel Expert 2010
4. Working with Macros and Forms
4.2. Insert and manipulate form controls

Create the Combo Box 
After you select the Combo Box Control, you 
need to draw the Control in your 
spreadsheet.

2. Try it: Create the Combo Box
Drag the size of the Combo so that would fit 
in Cell A2.

What Else Do You See? The Combo Box is 
a Shape. When you select the Combo Box, 
the Drawing Tools should be available as 
well. 

Keep going...!

Developer ->Controls
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Exam 77-888: Microsoft Excel Expert 2010
4. Working with Macros and Forms
4.2. Insert and manipulate form controls

Edit the Control Properties 
All Combo Boxes need a reference table to 
look up the values. Earlier in our lesson, we 
created a table and named the range Clients. 

3. Try it: Edit the Control Properties
Click once on the Combo Box to select it.
Go to Developer ->Controls.
Click on Properties.

What Do You See? Each Control has 
Properties that you can edit. The Properties 
include Size, Protection, Properties, Alt Text 
and Control.

Try This, Too: Edit the Input Range
Input Range: Clients

Click OK. Keep going...!

Developer ->Controls ->Properties
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Exam 77-888: Microsoft Excel Expert 2010
4. Working with Macros and Forms
4.2. Insert and manipulate form controls

Test the Control  
4. Before You Begin: Deselect the Combo
When you are working on a Control, you 
should see Handles in each corner, just like 
when you select a picture or chart. This is the 
Developer's view. 

When you deselect the Combo Box. (Click on 
anything else) the Combo Box will look and 
behave as it should when a user clicks on it.

Try This: Test the Control
Go to the Combo Box and select a Client.

What If It Doesn't Work? 
There are two parts to the test: 
1. Can you click on the Combo Box and see 
the list of reference names? 
2. Can you select an item from the list? 

If you cannot see the list, then check the 
spelling of the Named Range. 

Memo to Self: This control does NOT 
include the equals (=) sign in the Input 
Range, just the name of the Named Range. 

Developer ->Controls
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Exam 77-888: Microsoft Excel Expert 2010
4. Working with Macros and Forms
4.2. Insert and manipulate form controls

Copy the Control 
This little Combo Box works, now. Here 
are the steps to copy and paste the 
control to the other Cells in the Time 
Sheet.

5. Try it: Copy and Paste the Control
Right-click the Control to select it. You 
should see Handles in each corner.
Go to Home ->Copy.
Click on Cell A3.
Go to Home-> Paste.

Paste the Control in Cells A4 through 
A12.

Do This, Too: Save Your Work
Go to File->Save.
Type the File Name: MyName Timesheet
Click on Save.

Very good.

Home ->Copy
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Controlling Data Entry 
What Do You Think?  Making a 
Combo Box with Visual Basic is 
similar to creating a Drop-Down list 
with Data Validation.

Data Validation is a simple, user-
friendly tool. Designing Visual Basic 
applications takes some thought. 

Programming adds a responsive 
element: What happens when a user 
selects something from the list? 
What if a user enters something that 
isn't on the list? 

Both methods look up the data in a 
reference table. Both Controls 
enable the user to select an item 
from a list.

Developer ->Controls
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Summary 
Our lesson began by creating a timesheet 
that looks up the clients in a reference 
table. We designed two different Combo 
Boxes and tested them.

This is a good introduction to Form 
Design. Our discussion continues with a 
beginner's guide to Macros that can be 
found in the Appendix at the end of this 
book.  

If you enjoy programming and developing 
forms, it is an excellent field to consider 
following up with additional training. Form 
Design and programming pay well.

You done good.
You get the cookie this time.

Developer ->Controls
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Lesson 5: Working Overtime
Before You Begin: Start Microsoft Excel 2010. 

Try This: Do the following steps
1. Open the MyName Timesheet that you created earlier 
in this lesson.
2. Go to the Timesheet and select Cell H13. In this 
example, it is the Cell that Sums the total hours worked.
3. Go to Home->Styles-> Conditional Formatting.
4. Select: Highlight Cell Rules-> Greater Than...
5. Format Cells that are Greater Than: 40 
   With: Green Fill and Dark Green Text

6. Click OK and test the formatting as follows: 
Enter sample data in the Time Sheet so that each day of 
the week, (Monday through Saturday has 8 hours. The 
Sum in Cell H13 should be 48, which is greater than 40.
7. Save this as YOUR NAME Working Overtime Practice.

4. You can Autofill data validation
a. True
b. False
Tip: Advanced Excel, page 181

5. Which Ribbon has the commands for 
Form Controls?
a. Developer Ribbon
b. Insert Ribbon
c. Data Ribbon
d. Review
Tip: Advanced Excel, page 186

6. Which of the following is true about 
Combo Boxes? 
(Select all correct answers.)
a. It’s a shape
b. It has Drawing Tools available
Tip: Advanced Excel, page 188

1. Data Validation alerts a user if the 
typed data does not match the set value.
a. True
b. False
Tip: Advanced Excel, page 171

2. Which of the following are options for 
Data Validation? 
(Select all correct answers.)
a. Settings
b. Input Message
c. Error Alert
Tip: Advanced Excel, page 172

3. Which of the following are options for 
Data Validation error message options?
(Select all correct answers.)
a. Retry: leaves the error
b. Cancel: clears the error
c. Help: opens Excel’s help menu
d. Ok: Accepts the error
Tip: Advanced Excel, page 174

Practice Activities Test Yourself
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© 2011 Comma Productions

Excel 2010: Sharing and Collaboration

Advanced Excel Objectives
In this lesson, you will learn how to: 
1. Use the Review Ribbon to proof a spreadsheet
2. Insert, edit, view and manage reviewer's comments
3. Track the changes that each reviewer makes and 
accept or reject those changes
4. Compare two similar versions of the same 
spreadsheet and combine them into one file
5. Apply protection and sharing to spreadsheets and 
to workbooks prior to sharing your work
6. Restrict Permissions on worksheets, workbooks 
with Passwords and Digital IDs

Prepare to Share
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1. Readings
Read Lesson 6 in the Advanced Excel 
guide, page 195-243.

Project
This lesson shows how to prepare a file for 
sharing including: proofing, comments, and 
tracking changes. The lessons will show 
how to protect and share a spreadsheet or 
a workbook.

Downloads
Customer Sales 2010 PivotChart.xlsx.
Time Sheet 2010.xlsx (complete)

2. Practice
There is no Practice Activity in this lesson.

3. Assessment
Review the Test questions on page 244.

Menu Maps
From the Backstage 
1. File ->Options-> Quick Access, page 220
2. File ->Info-> Properties, page 223
3. File ->Info->Check for Issues, page 224
4. File ->Info->Permissions, page 229

Menu Maps
From the Review Ribbon.
1. Review ->Proofing-> Spelling, page 200
2. Review ->Proofing-> Research, page 201
3. Review ->Proofing-> Thesaurus, page 203
4. Review ->Language-> Translate, page 205
5. Review ->Comments, page 215
6. Review ->Changes-> Protect Sheet, page 206
7. Review ->Changes-> Protect Workbook, page 207
8. Review ->Changes-> Share Workbook, page 208
9. Review ->Changes-> Track Changes, page 211

Review Ribbon

Review Ribbon

Lesson 6 Sharing and Collaboration: Prepare to Share

Comma Training Page 196

Advanced Excel 2010 Page 196 of 298



Start -> All Programs ->Microsoft Office-> Microsoft Office Excel 2010

Sharing Data and Working Together
My mentor, Fr. Paul, talked about an old church where the sisters kept all of the vital records on index cards for 
over 40 years: thousands of births, deaths, marriages and family details. The records were stored in boxes and 
trunks in the basement of the rectory. Who could ever find anything in those boxes and boxes of index cards? 
How could anyone ever connect the names and the families?

Information is vital to a community as well as a company. However, people need a way to access and use that 
data. Otherwise it is just noise. This lesson looks at the options for sharing and collaborating.
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Before You Begin
This lesson uses a sample spreadsheet 
which is available online. You can create your 
own spreadsheet if you wish. When you are 
ready, please start Microsoft Excel.

1. Try This: Open a Sample Spreadsheet
Open a sample spreadsheet: 
Customer Sales 2010 PivotChart.xlsx
Go to the Monthly Sales sheet.

What Do You See? This sheet shows the 
product sales for Charlotte' Website. The first 
row is BOLD: It is the Header Row. There are 
many rows of data. The example on this page 
has been sorted by Column C, Category.
Please keep going...

Memo to Self: You do not have to MATCH 
the numbers shown on these pages. It is 
more important that you begin with some 
data and understand the options.

File->Open
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Review: Proofing 
Microsoft Excel 2010 gathers all of the 
proofing tools on the Review Ribbon..

2. Try it: Review Your Spreadsheet
Go to the Review Ribbon.

What Do You See? There are four 
groups on the Review Ribbon:
Proofing
Language
Comments
Changes

Keep going...!

Review ->Proofing
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Review: Spelling 
Most people see Numbers when they think of 
spreadsheets. However, our products and 
customers names are Text. So, you need to 
proof and spell check your spreadsheets.

Try it: Check the Spelling
Go to Review ->Proofing.
Click on Spelling and Grammar

Excel will review the Spelling in your data 
and alert you when there is something that 
does not match a word in the dictionary. 

You can choose Suggestions from the list. 
You can also Ignore or Add to Dictionary.

Review ->Proofing-> Spelling
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Review: Research 
Sometimes it is better to look something up, 
rather than just guess at the right answer. You 
can use the Proofing tools to Research the 
spelling as well as the meaning.

1. Try it: Research a Word
In this sample spreadsheet, there is a client 
named Harmony and Me Sushi. This example 
will research the word "sushi."

Select Cell B4.
Go to Review ->Proofing-> Research
The Research Pane should be available on the 
right. The default search option is Reference 
Books. Select: All Research Sites.

Search For: Sushi

What Do You See? The Research results on 
this page shows answers from Wikipedia, an 
online encyclopedia, as well as many other sites 
including a South Park cartoon video about 
sushi.

Review ->Proofing-> Research
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Review: Research Options 
Microsoft Office 2010 uses the Internet to find 
answers. By default, the Research Pane may 
show only one web site. 

You can edit the Search options to show:
All Reference Books (Dictionary, Thesaurus)
All Research Sites
All Business and Financial Sites

2. Try This: Edit the Research Options
At the bottom of the Research Pane you may 
see a link for Research Options.

When you click that link you should see a list 
of the sites you can use.  

If you don't see the site you want for your 
work, you can also edit this list. The options 
include Add Services, Update/Remove and 
Parental Control. 

Please click OK and keep going...

Review ->Proofing-> Research-> Research Options
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Research: Thesaurus 
A Dictionary, like the research answers on 
the previous page, offers the correct spelling, 
definition and pronunciation of words. 

A Thesaurus looks up words that are related. 
They can have a similar meaning. These are 
synonyms. The Thesaurus can also list words 
that have mean the opposite: the antonyms. 

1. Try This: Use the Thesaurus
Select Cell C2, or any sample Cell that has 
the word: Private.
Go to Review ->Proofing.
Click on Thesaurus.

Keep going please...

Review ->Proofing-> Thesaurus
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Thesaurus Options 
2. What Do You See? The Research Pane will 
display words that are related to the one you 
searched. You can click on any word to see 
additional suggestion. You can also use the 
Back button to page back to a previous word.

When you find a good word, click on the option 
arrow on the right side. The Thesaurus has 
three options: 
Insert
Copy
Look Up

You can Insert a word if you wish.

Review ->Proofing-> Thesaurus
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Review: Translate Text
You can use the Translate option to translate 
your text into a different language. 

Try This: Translate Selected Text
Selectany sample Cell and type: Banquet.
Go to Review ->Language-> Translate.
Choose a Language.

What Do You See? The Research Pane 
should bring up different translations.

Memo to Self: The Computer Mama sez it 
would be a good idea to have a professional 
review your translations if you are not fluent 
in the language. There are legends about the 
translation mash up that happened when 
WANG computers introduced their desktop 
computers in the United States in the 1980's.

Review ->Language-> Translate
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.2. Apply protection and sharing properties to workbooks and worksheets

Prepare to Share
Say you are ready to send this workbook 
around the office for comments and 
review. Before you send it around the 
office you may wish to consider if you 
should Share or Protect your work. Let's 
think about Protecting the data. When you 
Protect a sheet or workbook, you are 
restricting what users can or cannot do.

1. Try it: Protect the Sheet
Go to Review->Changes.
Select Protect Sheet.

What Do You See? You will be prompted 
to Protect worksheet and contents. By 
default, when you Protect a worksheet all 
of the cells will be locked. You can select 
which options you would allow your users 
to do, such as Insert row or Format cells.

You can enter a Password to unprotect 
the sheet, or not. 

Click CANCEL and keep going, please.

Review ->Changes-> Protect Sheet
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.2. Apply protection and sharing properties to workbooks and worksheets.

Protect the Workbook 
Every Microsoft Excel Workbook has a 
structure. The workbook structure includes 
sheets that are visible, others that are hidden. 
The structure can also include the size and 
position of the windows. 

When you Protect a Workbook, you prevent the 
users from finding hidden sheets or changing the 
data. Workbook Protection is applied to the 
entire workbook and all of the spreadsheets 
in it.  Before you lock the Workbook you can 
choose cells you would like unlocked so the 
users can enter data.

2. Try it: Protect a Workbook
Go to a Review ->Changes.
Click on Protect Workbook.

What Do You See? By default, there is 
checkmark to Protect the Structure. 

You will be prompted to enter a Password. Write 
it down. Not even Microsoft can unlock a 
Workbook if you lose the Password.

Click CANCEL and keep going...

Review ->Changes-> Protect Workbook
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.2. Apply protection and sharing properties to workbooks and worksheets.

Share a Workbook 
This discussion began by reviewing the 
steps to Protect a sheet or workbook. 
The next pages will look at how to Share.

3. Try it: Share a Workbook
Go to Review ->Changes.
Click on Share Workbook.

What Do You See? By default, there is a 
check mark to allow changes by more 
than one user at the same time. The 
Editing tab also displays who currently 
has the  workbook open.

What Else Do You See? Before you 
Share a Workbook, it will be marked as 
Exclusive: only one person can edit it at 
a time. After you Share a Workbook, it will 
no longer be listed as Exclusive.

Keep going..

Review ->Changes-> Share Workbook
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.2. Apply protection and sharing properties to workbooks and worksheets.

Advanced Sharing  Options
In addition to the Editing options, there are 
Advanced options when you Share a 
Workbook. Let's review them now.

4. Try it: Review the Advanced Options
The Advanced Sharing options include:

Track Changes: You can keep a history of 
all the changes and specify how many days 
you need to keep in the log..

Update Changes: By default, the changes 
are updated each time a file is saved. They 
can also be set to update automatically.

Conflicting changes between users: You 
can choose to be asked ore let the last saved 
change "win."

Include in personal view: The Print and 
Filter settings are both included by default.

Click CANCEL and keep going...

Review ->Changes-> Share Workbook
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.2. Apply protection and sharing properties to workbooks and worksheets.

Protect and Share
If you are editing this workbook in a group or 
department, you can Protect and Share your 
workbook. Here are the steps.

5. Try it: Protect and Share
Go to Review->Changes.
Select Protect and Share.

What Do You See? When you Protect and 
Share a Workbook, this option turns on the 
Tracking and prevents folks from turning the 
Tracking off.

What Else Do You See? You can enter a 
Password as well. The Password is optional.

When you click OK this workbook will be 
Shared. Click OK and keep going...

Review->Changes-> Protect and Share
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.3. Maintain shared workbooks: Track Changes

Review: Track Changes
You can Track each person who reviews this 
spreadsheet and if they made any changes. 

Each reviewer's changes can be highlighted 
in a different color. If you choose to Track 
Changes, you can see which changes were 
made, who made the changes and where you 
can find their changes. 

6. Try it: Track Changes
Go to Review->Changes.
Go to Track Changes->Highlight Changes.

Keep going...

Review ->Changes-> Track Changes->Highlight Changes
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.3. Maintain shared workbooks: Highlight Tracked Changes

Track Change Options 
7. What Do You See? You will be prompted 
to choose which changes you would like to 
highlight. The options include:

When: Since I last saved. 
The other options are All, Not Yet Reviewed, 
and Since Date...

Who: Everyone. 
The other option is Everyone but me.

Where: By default this is blank.
You can select a range of cells to Track.

What Else Do You See? There should be a 
check mark to Highlight changes on 
screen.

Click OK and keep going...

Review ->Changes-> Track Changes

Comma Training Page 212

Advanced Excel 2010 Page 212 of 298



Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.3. Maintain shared workbooks: Highlight Tracked Changes

Review the Tracked Changes 
So, what does Tracking look like? In this 
sample spreadsheet there are 7 records for 
"Cold Platter." Let's Find and Replace "Cold 
Platter" with "Pita Platter."

8. Try it: Make Some Changes
Select Column E: Products.
Go to Home->Editing->Find and Select.
Click on Replace.

You will be prompted to enter the following:
Find What: Cold Platter
Replace With: Pita Platter
Click Replace All to make 7 replacements.

What Do You See? There should be a 
border around the cells that were changed. 

When you run your cursor over the 
highlighted cell you should see the name of 
the person who changed the data, when it 
was changed and what was changed.

One more time, keep going...!

Home->Editing->Find and Select-> Replace
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.3. Maintain shared workbooks: Accept or Reject Tracked Changes

Accept or Reject the Changes 
As you review the tracked changes, you can 
choose to Accept or Reject those changes.

9. Try it: Select Changes
Go to Review ->Changes-> Track Changes.
Click on Accept or Reject Changes.

You will be prompted to select which changes. 
When: Not yet reviewed
Who: Everyone
Click OK.

Try This, Too: Accept or Reject Changes
The options include:
Accept
Reject
Accept All
Reject All
Accept All Changes and Close the window.

Very good.

Review ->Changes-> Track Changes-> Accept or Reject Changes
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Exam 77-882: Microsoft Excel 2010 Core
7. Sharing worksheet data with other users
7.2. Manage comments: Edit Comments

Review:  Add a Comment 
How do you scribble your observations or 
corrections on a spreadsheet? In Microsoft 
Excel you can use Comments to share your 
thoughts with your team. 

Before You Begin: The examples on this 
page are from the Sample PivotTable.

1. Try This: Add a Comment
Select Cell B4.
Go to Review ->Comments.
Click on New Comment.

What Do You See? A new comment will be 
placed in your spreadsheet. The comment on 
this page shows that it was added by eBeth.

Keep going, please...

Review ->Comments-> New Comment
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Exam 77-882: Microsoft Excel 2010 Core
7. Sharing worksheet data with other users
7.2. Manage comments: Edit Comments

Review: Edit Comments 
When you create a new comment, your 
cursor should be in the balloon, ready to type. 
Here are the steps to Edit the Comment. 

2. Try it: Edit the Comment
Select Cell B4 (The one with the Comment).
Go to Review ->Comments.
Click on Edit Comment.
Type: The rows are FILTERED to show only 
our new products

What Do You See? A Comment is a special 
Text Box. You can edit the Comment to make 
it taller or wider if you wish.

Keep going...

Review ->Comments-> Edit Comment
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Exam 77-882: Microsoft Excel 2010 Core
7. Sharing worksheet data with other users
7.2. Manage comments: Manage Comments

Review the Comments 
Look again at the Review Ribbon. The 
Comments group has a couple of useful 
buttons for navigation and display.

Before You Begin: Select 2 or 3 different 
cells and add a Comment (e.g. Comment1, 
Comment2) to each one.

3. Try This: Review the Options
Go to Review ->Comments.
Navigate around the Comments with the 
Previous and Next options.

What Else Do You See? When you select a 
Comment you can also Delete it. 

Review ->Comments-> Edit Comment
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Exam 77-882: Microsoft Excel 2010 Core
7. Sharing worksheet data with other users
7.2. Manage comments: Manage Comments

Show/Hide Comments 
Say your workbook has Comments from 
several Reviewers. You can choose which 
ones should be shown or hidden.

4. Try This, Too: Show/Hide the 
Comments
Go to Review ->Comments.
Click on Show/Hide Comment.

What Do You See? There should be a small 
triangle in the upper right corner of the cell 
that has a Comment.

OK, that completes this discussion on the 
Review Ribbon: Proofing, Language, 
Comments and Changes. 

SAVE your changes, please.

Review ->Comments-> Show/Hide Comment
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.3. Maintain shared workbooks

Working Together 
Say two people need to work on the same file 
at the same time. How would you compare the 
two files and merge the changes? Microsoft 
Excel 2010 has a tool you can add that 
automates the steps: Compare and Merge 
Workbooks.

1. Here are some thoughts to consider:

Where are you sharing your work?
For the best results, you need to save all of the 
shared copies in the same folder on the server. 

Where is the command button?
You also need to customize the Quick Access  
and add the Compare and Merge
Workbooks  button. This option is NOT 
available in the Review Ribbon by default.

Working With the Same Shared Copies
Compare and Merge Workbooks only works 
with copies of the same Shared workbook. It 
cannot be used to combine workbooks that are 
not Shared. 

Keep going...
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Exam 77-882: Microsoft Excel 2010 Core
1. Managing the Worksheet Environment
1.3. Personalize environment by using Backstage

Add a Command to the 
Quick Access Toolbar
Here are the steps to customize the 
Quick Access Toolbar and add the 
Compare and Merge Workbooks button.

Before You Begin: The sample 
workbook, Customer Sales 2010 
PivotChart.xlsx, is open and Shared. 

2. Try This: Add Compare and Merge 
Workbooks to the Quick Access 
Toolbar
Go to File ->Options.
Click on the Quick Access Toolbar tab.

Customize the Quick Access Toolbar
Choose commands from: All Commands.
Select Compare and Merge Workbooks.
Click Add.

The Compare and Merge Workbooks
command should be displayed on the 
right side. Click OK. Keep going...!

File ->Options-> Quick Access Toolbar
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.3. Maintain shared workbooks

Compare and Merge 
The Quick Access Toolbar should have a 
new button, Compare and Merge 
Workbooks. In the image on this page the 
custom button is to the right of the Undo and 
Redo arrows.

3. What if two people edit the same file?
Say there are two people who go to the same 
folder and open the same Shared workbook.

Say User2 clicked on Find and Replace to get 
all of the Pita Platter sales and format the data 
orange. User2 then SAVED her changes.

Keep going...

Memo to Self: Some of these examples 
cannot really be tested if you are working 
alone.

Quick Access Toolbar ->Compare and Merge Workbooks
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.3. Maintain shared workbooks

Updating the Shared File 
4. What happens when you click on 
Compare and Merge Workbooks?
User1 and User2 both made changes to 
the same workbook. Say User1 went to 
the Quick Access toolbar and clicked 
Compare and Merge Workbooks.

Microsoft Excel will update User1's copy 
of the spreadsheet with User2's changes. 
A small window will pop up confirming that 
your workbook has been updated.

That was it: Excel compared both 
versions of the Shared workbook and 
updated User1's copy.

That's that...Let's take up a new topic.

Quick Access Toolbar ->Compare and Merge Workbooks
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Document Properties

Document Properties
Every file has Properties. The basic Properties 
include the name of the file and when it was 
created or modified. 

1. Try it: Find the Properties
Go to File ->Info-> Properties.

What Do You See?  The Properties include:
Size
Title
Tags
Last Modified
Created
Last Printed
Author
Last Modified By

Keep going, there's more...

File ->Info-> Properties
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Document Properties

Edit the Properties 
Most of the Properties are updated by the 
computer when you SAVE a file. Some of the 
Properties can be customized.

2. Try it: Open the Advanced Properties
Go to File ->Info-> Properties.
Click on Advanced Properties.

What Do You See? A Property Sheet with 5 
tabs should open. The General tab displays 
the same basic information that was available 
in the Backstage View: name and dates.  

Try This, Too: Edit the Summary
You can edit many fields on the Summary 
tab:
Title
Subject
Author
Manager
Company
Category
Keywords (that's metadata)
Comments

Type some sample data and keep going...

File ->Info-> Properties
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Check for Issues

Inspect the Document
Prior to posting your work on a shared network 
drive or on the Internet you should Inspect the 
Properties for metadata or personal 
information. 

3. Try it: Inspect the Document
Go to File->Info.
Go to Check for Issues.
Click on Inspect Document.

What does it do? Keep going to find out...

File ->Info->Check for Issues-> Inspect Document
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Check for Issues

The Document Inspector 
4. What Do You See? 
Meet the Document Inspector. 

This tool reviews your work and looks for:
Comments and Annotations
Document Properties and Personal 
Information
Custom XML Data
Headers and Footers
Hidden Rows and Columns
Invisible Content

If the Document Inspector finds any 
metadata or personal information, you will 
be prompted to ignore or delete it.

Memo to Self: Hidden Data cannot be 
removed in Shared Workbooks.

File ->Info->Check for Issues-> Inspect Document
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Check for Issues

Check Compatibility 
Microsoft Office 2007 and Office 2010 are in 
a new file format: XML (Extended Markup 
Language). All new files now have four letter 
extensions. For example, Excel 2010 
workbooks are saved as myname.xlsx. 

The format is so different that older versions 
of Microsoft Office cannot even open the new 
files without a free add-on. People are slow to 
upgrade their systems. So, there may be 
some Compatibility issues.

5. Try it: Check Compatibility
Go to File ->Info->Check for Issues.
Click on Compatibility Checker.

Compatibility issues are grouped into 2 
categories: Significant and Minor loss of 
functionality. What do you lose? The new 
Themes and Styles are not supported by 
earlier versions of Microsoft Office. New 
functions such as Sparklines and PivotTable 
Slicers are not supported, either.

(Aw, you never let me have any fun.)

File ->Info->Check for Issues-> Compatibility Checker
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Check for Issues

Accessibility Checker 
Computers have always helped people with 
disabilities access information. Since the 
early days of Windows 95, computers could 
read text out loud as well as type what was 
said. The assistive technology needs your 
input, though. For example, pictures and 
charts should have Alternative Text (Alt Text)  
that describes the graphic. 

6. Try it: Run the Accessibility Checker
Go to File ->Info->Check for Issues.
Click on Accessibility Checker.

What Do You See? The Accessibility 
Checker should be available on the right side 
of your screen. The Inspection Results will 
list Errors and Warnings. 

What Else Do You See? Select an Error or 
Warning and look at the bottom of the 
Accessibility Checker. There should be a 
summary of the problem and suggestions for 
how to correct it.

OK, SAVE and CLOSE this workbook. 

File ->Info->Check for Issues-> Accessibility Checker
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Check for Issues

Permissions and Protection
Security and permissions can be set at many 
levels. Earlier in this lesson we looked at how 
to Share or Protect a sheet or a workbook for 
changes and comments. The following pages 
will discuss Permissions using the Microsoft 
Excel 2010 Backstage properties.

Before You Begin: This lesson will use a 
different sample file that has NOT been 
Shared or Protected.

1. Try it: Review the Permissions
Open the spreadsheet: Time Sheet 2010
Go to File ->Info->Permissions.
Click on Protect Workbook.

What Do You See: The Permissions are:
Mark as Final
Encrypt with Password
Protect Current Sheet
Protect Workbook Structure
Restrict Permission by People
Add a Digital Signature.

Let's review these options. Keep going...

File ->Info->Permissions->Protect Workbook
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Mark As Final

Permissions: Mark As Final 
Say the spreadsheets are proofed, corrected 
and ready to go. When you Mark as Final 
you are indicating that this file is done: do not 
edit it anymore.

2. Try it: Mark As Final
Go to File ->Info->Permissions.
Go to Protect Workbook.
Click on Mark As Final

What Do You See? You may be prompted to 
SAVE your work before it is Marked Final.

A second message may pop up saying that 
this step will make the file Read Only.

Keep going..

File ->Info->Permissions->Protect Workbook->Mark As Final
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Mark As Final

Mark As Final: Edit Anyway 
3. What Do You See? If you return to the 
Home Ribbon, you will see a yellow security 
banner at the top of the spreadsheet 
indicating that the file has been marked as 
final.

What Else Do You See? There is an option 
to override the author and edit the file 
anyway.
If you click Edit Anyway, the file will no 
longer be Read Only and you can change the 
data.

So, this is not secure. 

Do This, Too: Remove the Read Only
Click on Edit Anyway. Keep going...!

File ->Info->Permissions->Protect Workbook->Mark As Final
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Require a Password

Password Protect a File 
Adding a Password to a file increases the 
security. This is called encryption. 

Passwords should not be easy to guess, 
such as your name or birthday. You should 
choose a password that is at least 6 
characters long and includes letters and 
numbers.

4. Try it: Encrypt the Document
Go to File ->Info->Permissions.
Go to Protect Workbook.
Click on Encrypt with Password.

What Do You See? You will be prompted to 
enter a password. Anyone who opens your 
file will be asked for a password as well.

Click CANCEL. Keep going...

Memo to Self: Microsoft takes security 
seriously and strives to meet Department of 
Defense standards. There is NO UNDO if you 
forget the password!

File ->Info->Permissions->Protect Workbook->Encrypt with Password
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Add a Digital Signature

User Permissions 
The security settings shown in the previous 
pages are "all or nothing." Either the file is 
locked or it is not. The Permissions are 
applied to the sheet or to the entire 
workbook. 

1. Introduction to Permissions by People 
Permission can also be based on Users and 
Groups. When you Restrict Permissions by 
People you can decide who has access to 
your file. The Permissions are authenticated 
by Digital Signatures: each person has a 
secure ID that identifies them. 

So, this process has two steps: getting a 
Digital ID, and then granting Permission to 
Digital IDs that you trust. 

A Digital Signature shows who signed this 
document and if it was changed since it was 
signed. It is a method for determining if the 
email, spreadsheet or document is authentic.

Keep going...

File ->Info->Permissions->Protect Workbook->Add a Digital Signature
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Add a Digital Signature

Create a Digital Signature 
A Digital Signature can be created in 
Windows, not Word. The steps are given, 
below. The certificate created with this 
program is "self-signed," which means that 
it is not independently verified by a 
commercial signing server. So, this self-
signed certificate is for personal use, only.

2. Try it: Add a Digital Signature
Go to Start ->All Programs.
Go to Microsoft Office.
Go to Microsoft Office Tools.
Click Digital Certificate for VBA Projects

You will be prompted to enter a name for 
your certificate. When you click OK, you 
should see a little window that confirms 
your signature was created successfully.

Please return to Excel and keep going.

Start ->All Programs->Microsoft Office->Microsoft Office Tools->Digital Certificate for VBA Projects
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Add a Digital Signature

Sign a Document 
Here are the steps to add a Digital Signature 
to a spreadsheet. We'll go to the Backstage.

3. Try it: Add a Digital Signature
Go to File ->Info->Permissions.
Go to Protect Workbook.
Click on Add a Digital Signature.

What Do You See? You will be prompted to 
enter the Purpose for signing this 
document. The notice also indicates that this 
signature will not be visible within the data.

Try This, Too: Type the Purpose
Purpose: To encrypt confidential sales data
Click on Sign.

You should see a Signature Confirmation.
Click OK and keep going...

File ->Info->Permissions->Protect Workbook->Add a Digital Signature
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Add a Digital Signature

Signed Workbook Permissions 
4. Try it: Review the Permissions
When you Sign a Workbook it will be marked as 
Final in the Permissions. 

A Signed Workbook has a Digital Signature. It 
is an electronic seal, like a bee wax seal on 
letters. The bees wax would be imprinted with 
the ring of the man who signed and sealed the  
document.

What Do You See from the Home Ribbon? 
A Signed Document will have a security banner 
at the top under the Ribbons. There is a warning 
that the document has been Marked As Final. 
There is also a button to Enable Editing. 

If anyone edits the Signed Document, the 
security banner will warn that the signature 
would be invalid and it will be removed.

Keep going...!

File ->Info->Permissions->Protect Workbook->Add a Digital Signature
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: restricting Permissions

Restricting Permissions 
So far, so good. In the previous pages we 
created a Digital ID and signed a document. 
The next step is to restrict permission to people 
you trust. The people you trust will be identified 
by their Digital ID as well. Here are the steps.

5. Try it: Restrict Permission by People
Start the process by going to the Backstage.

Go to File ->Info->Permissions.
Go to Protect Workbook.
Go to Restrict Permissions by People.
Click on Restricted Access.

Keep going...

File ->Info->Permissions->Protect Workbook->Restrict Permissions by People.
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: restricting Permissions

emails are NOT stored on a server at Microsoft.

Microsoft Information Rights 
Management Services 
When you click on Restrict Permissions by 
People you will be prompted to sign up for a 
authentication servicer. You need a server to 
effectively manage Users, User Groups and 
Permissions. Some companies have their own sever 
that checks users credentials. Microsoft offers a free 
service online.

Information Rights Management Service
IRM is a licensing program, basically. You add a 
Use License to each file you want to restrict and 
indicate which people can use this file. 

When you open a restricted file, you need to be 
online so that you can connect to a server, show 
your credentials, and download a use license. The 
use license say what permissions you are given: 
Read, Write, Edit, Save or Print.

6. Try it: Setup the IRM Service
Click on Restrict Permissions by People.
You will be prompted to sign up for the service. 
Click NEXT and keep going...

File ->Info->Permissions->Protect Workbook->Restrict Permissions by People
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: restricting Permissions

Sign in to IRM 
The IRM service uses a Windows Live ID to 
identify you. Getting  a Windows Live ID is 
simple and free. Windows Live ID can be a 
Hotmail and MSN Email account. It can also 
be the same Live ID that you use to log into 
your online gaming. 

As you walk through the IRM setup wizard, 
you will asked if you have a Windows Live ID 
or if you need to create a new one.

That's it. The next step is to log into the 
Information Rights Management Service.
Enter you Email address and Password.

7. Try it: Sign in to the IRM Service
Enter your Windows Live Email address.
Indicate if this is Public or private computer.

Click Sign In and keep going, please..

File ->Info->Permissions->Protect Workbook->Restrict Permissions by People
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: restricting Permissions

IRM: Select a User 
8. Try it: Select a User
The first user you should see in your IRM 
account would be the one you just created. 

You can click on Add to find or create more 
user accounts. Obviously, you can also select 
a user and Remove their Digital ID.

Click OK and keep going...
(We're almost done...really!)

File ->Info->Permissions->Protect Workbook->Restrict Permissions by People
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: restricting Permissions

IRM: Restrict Permissions 
9. Try it: Restrict Permission by User
There are two levels of permission: Read and 
Change. A User with only Read access can 
"look but don't touch." Read access users 
can look, but they cannot edit, copy or print 
the information in your Microsoft Excel 
workbooks.

To the left is a button to look up users who 
have a Windows Live ID.

Keep going...

Where Have You See This Before? Just like 
in Microsoft Outlook, an underline confirms 
that this is indeed a valid email address (It is 
spelled right.)

File ->Info->Permissions->Protect Workbook->Restrict Permissions by People
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: restricting Permissions

Restricted Permissions 
What Do You See? The Permissions
shown in the Backstage view are Exclusive: 
no one else can open or read this file.

What Else Do You See? When you go to the 
Home view you should see a yellow security 
banner that indicates Restricted Access. 

There is a button to Change Permissions.
If you go to More Options you can set the 
expiration date for these permissions. 

You can also include an email address so 
that someone can contact you regarding the 
permissions.

Very good!

File ->Info->Permissions->Protect Workbook->Restrict Permissions by People
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Summary 
This lesson began by preparing your work for 
distribution or publication. The Review
options included Proofing, Tracking, 
Comments and Changes. We considered 
how to collaborate on a file and combine 
different versions into one final workbook.

Share or Protect? The security options were 
taken seriously. We looked at everything from 
Read Only to Restrictions based on a 
verifiable Digital User ID.

Well, you done good on this one. You get two 
cookies if you wish.
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8. Which of the following are document 
properties? (Select all correct answers.)
a. Size
b. Title
c. Last Modified
d. Created
e. Author
f. Last Printed
Tip: Advanced Excel, 223

9. What is the new Excel file format used in 
Office 2007 and 2010?
a. .xls
b. xlsx
c. .xlst
d. .exl
Tip: Advanced Excel, page 227

10. Which of the following is true about the 
Mark as Final command? 
(Select all correct answers.)
a. It is to discourage editing
b. A file marked as Final has the ribbons 
removed
c. A file marked as Final cannot be edited
Tip: Advanced Excel, page 231

4. Which of the following are true about 
the Protect and Share options? 
(Select all correct answers.)
a. The Tracking is turned on 
b. The Workbook is shared
c. A Password is required
Tip: Advanced Excel, page 210

5. Which of the following are Reviewing 
options? (Select all correct answers.)
a. Accept 
b. Reject
c. Accept all
Tip: Advanced Excel, page 214

6. More than one person can add a 
comment on an Excel spreadsheet.
a. True
b. False
Tip: Advanced Excel, page 218

7. Which is true about Compare and 
Merge? (Select all correct answers.)
a. Only works on a Shared Workbook
b. Command is NOT available in 
Reviewing Ribbon by default
c. Works on any workbook
Tip: Advanced Excel, page 219

1. Which Group(s) are on the Review 
Ribbon? (Select all correct answers.)
a. Proofing 
b. Language
c. Comments
d. Changes
Tip: Advanced Excel, page 199

2. Spreadsheets can be spell-checked.
a. True
b. False
Tip: Advanced Excel, page 200

3. Which of the following actions can be 
restricted in the Protect Sheet 
command? (Select all correct answers.)
a. Format Cells
b. Format Columns
c. Format Rows
d. Insert Rows
e. Insert Columns
Tip: Advanced Excel, page 206

Test Yourself
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Excel 2010: Appendix

Advanced Excel Objectives
In this lesson, you will learn how to: 
1. Use the Developer Ribbon to record, save and 
run a simple Event Macro
2. Modify a Macro with the Visual Basic Editor
3. Create a custom Macro Button and assign it to 
the Quick Access Toolbar 
4. Run a Macro when a workbook is opened
5. Use the Developer Ribbon to record, save and 
run an Action Macro to export or import data from 
Excel

Introduction to Macros
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1. Readings
Read Lesson 7 in the Advanced Excel 
guide, page 245-292.

Project
This lesson provides an introduction into 
Visual Basic programming and Macros.

Downloads
Legs Eggs Pigs 2010.xlsx
Legs Eggs Pigs with Macros 2010.xlsm
tblCustomers.xml
Brown Bag Sales Team.xlsx

2. Practice
Do the Practice Activity on page 293.

3. Assessment
Review the Test questions on page 294.

More Menu Maps
From the Backstage 
1. File ->Options-> Customize Ribbon, page 262
2. File ->Save As Macro Enabled, page 269
3. File->Info->Enable Content, page 271
4. File ->Options->Trust Center, page 273

Menu Maps
From the Developer Ribbon.
1. Developer ->Code-> Record Macro, page 251
2. Developer ->Code-> Macro, page 254
3. Developer ->Code-> Visual Basic, page 255
4. Developer ->Code-> Relative References, page 
257
5. Developer ->XML->Source, page 280
6. Developer ->XML->Map Properties, page 281
7. Developer ->XML->Refresh, page 282
8. Developer ->Add-Ins, page 285
9. Developer ->XML-> Export, page 290

Developer Ribbon

Review Ribbon

Lesson 7 : Introduction to Macros
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Start -> All Programs ->Microsoft Office-> Microsoft Office Excel 2010

Working with Macros
A Macro is a series of steps that can be recorded and played back in order. A Macro can be created by recording your menu 
selections and clicks. There are several kinds of Macros, depending on the purpose and the actions. An Event Macro does 
something when you click on a button or a cell. A User-Defined Macro is programming that makes the computer do the 
work.

My mentor, Fr. Paul, wrote a financial database. He watched the church staff go through the process to create a new check 
entry: 8 steps. Count them again: 8 steps. So, he created a Macro that walked through the menus automatically. 
That's what Macros do: simplify the task. 
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What is a Macro?
Creating a Macro can be as simple as 
recording your mouse clicks as you go 
through a process in Microsoft Excel, 
Word, PowerPoint or Access. The steps 
are named and saved so that you can 
repeat the process again with one click.

All of the Microsoft Office 2010 programs 
use Visual Basic for Applications (VBA)
to create and edit Macros.

What Are We Going to Do? 
This lesson is an introduction to Macros 
and Visual Basic for Applications. It is not 
a comprehensive demonstration on Macro 
programming.

As you go through these simple examples 
consider how you can program Excel to 
make your tasks easier and efficient. 

Please keep going...

AddNewRow2 Macro: This is a PREVIEW of the completed lesson
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Before You Begin 
This lesson requires some preparation. Here is 
a summary of the requirements:

1. Enable the Developers Toolbar
The steps to enable the Developers toolbar 
can be found in the Advanced Guide to Excel 
2010 Page 184. 

2. Enable the Macros
The steps to enable Macros can be found on 
Advanced Guide to Excel 2010 Page 270. 
This lesson includes a discussion on macro 
security levels. 

3. Download a Sample Spreadsheet
The lesson has a sample workbook online 
which you can download if you wish. You can 
also create your own data from the lesson in 
the Intermediate Guide to Excel 2010, Page 
11. 

File ->Options->Customize Ribbon

Comma Training Page 249

Advanced Excel 2010 Page 249 of 298



Still Before You Begin... 
Try it: Open the Sample Spreadsheet
Open the spreadsheet you downloaded: 
Legs Eggs Pigs 2010.xlsx
Go to the Legs spreadsheet.

The Developer Ribbon is shown In the 
example on this page.

What Do You See? The fields in the Header 
Row are Date, Product, Net, Quantity and 
Revenue. The Columns are formatted for 
number: Column A is formatted for Date, 
Column C is formatted for currency.

What Else Do You See? The dates in 
Column A are a series. This series shows the 
workdays and skips the weekends.

Keep going...

Memo to Self: You do not have to MATCH 
the numbers shown on these pages. It is 
more important that you begin with some 
data and understand the options.

File ->Open
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Exam 77-888: Microsoft Excel Expert 2010
4. Working with Macros and Forms
4.1. Create and manipulate macros: Record a Macro

Record a Macro
The Macro Recorder follows your actions as 
you go through a process. Let's start with a 
simple Macro that inserts a Row and formats 
the Cells the 'Same as the Row Above.'

What are the steps to add a row?
Select a Cell
Use the Home Ribbon to Insert a Row
Use the Format Painter to format the new Row 
the same as the Row Above.

1. Try it: Record a Macro
Go to Developer ->Code.
Click on Record Macro.

What Do You See? You will be prompted to 
type a name for your Macro.
Type: AddNewRow 
(No spaces, please)

What Else Do You See? Your new Macro will 
be stored in This Workbook. Enter the 
description shown on this page if you wish. 

Keep going...

Developer ->Code-> Record Macro
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4. Working with Macros and Forms
4.1. Create and manipulate macros: Record a Macro

Record the Steps 
The Macro Recorder is ready, although 
you will not see a little media player or 
device. 

Go through the process of selecting a cell 
and adding a new row. The Macro 
Recorder will follow your actions.

2. Try it: Add a Row
Go to the Legs spreadsheet.
Select Row 21. 
Go to Home->Cells->Insert Sheet Row.

Use the Format Painter: 
Format Same As Above.

Select Cell A21.
Use the AutoFill: Fill Weekdays.

Keep going...

Memo to Self: The Macro Recorder 
tracks when the steps are right as well as 
when you make a mistake. You may wish 
to practice the steps a couple of times 
before you start the Macro Recorder.

Home->Cells->Insert Sheet Row
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Exam 77-888: Microsoft Excel Expert 2010
4. Working with Macros and Forms
4.1. Create and manipulate macros.

Stop the Recording 
After you insert and format the new row, you 
need to Stop Recording.

3. Try This, Too: Stop the Recording
Go to Developer ->Code.
Click on Stop Recording

Keep going...

Developer ->Code-> Stop Recording
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4. Working with Macros and Forms
4.1. Create and manipulate macros.

Find the Macro 
Where is the Macro? You can manage 
your Macros with the Macros button.

4. Try This: Find the Macro
Go to Developer ->Code-> Macros.

What Do You See? You should see 
AddNewRow listed in the Macro names.
The Macro options include:
Run
Step Into
Edit
Create
Delete
Options

The Description at the bottom of this 
example was added when the Macro was 
created and named. You can edit the 
description if you click on Options.. 

What Else Do You See? You can review  
the Macros in All Open Workbooks or 
This Workbook. Keep going...

Developer ->Code-> Macros
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Exam 77-888: Microsoft Excel Expert 2010
4. Working with Macros and Forms
4.1. Create and manipulate macros.

Hello, Visual Basic! 
The Macros are written in Microsoft's 
Visual Basic for Applications (VBA) 
programming language. Here are the 
steps to Edit a Macro in VBA.

5. Try it: Edit the Macro
Go to Developer ->Code.
Click on Macros.
Select a Macro: AddNewRow.
Click on Edit.

What Do You See? The VBA Editor 
should open in a new window. On the 
left side should be a VBAProject. 
Each sheet, and the tab name, is 
listed in the Excel Objects.

Keep going...!

Memo to Self: This is the same VBA 
editor that you can use in Microsoft 
Access, Outlook, PowerPoint and 
Word to program Macros.

Developer ->Code->Macros-> Edit
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4. Working with Macros and Forms
4.1. Create and manipulate macros.

Review the Code 
6. Try it: Review the Code
The Macro Code begins with:
Sub AddNewRow()
Where Sub means Subroutine. 

The next six lines are Comments. 
The Comments start with a quote 
mark. These Comments include the 
name and description for the Macro.

Selection.Insert Shift:=xlDown
This shifts the Rows down (x1Down).

The AutoFill is programmed for 
Weekdays (x1FillWeekdays)

What Else Do You See? Look at the 
Range for this Macro. There is a 
specific Cell selected ("A20") and a 
specific Range for the Destination:
("A20:A21").

That means our Macro adds a new 
Row at Cell A20. We can do better...

Developer ->Code->Macros-> Edit
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4.1. Create and manipulate macros.

Create Another Macro
The first macro used Absolute Cell References. 
You can also use Relative Cell References when 
you record your Macro. Relative References 
means the new Row will be added below any Cell 
that is selected when you run the Macro.

Before You Begin: Minimize Visual Basic. 
You should see your spreadsheet.

Delete the Sample Rows
Go to the Legs spreadsheet. 
Delete Row 21 and 22 (the new rows). 

Use Relative References
Go to Developer->Code.
Click on Use Relative References.

7. Try it: Create Another Macro
Go to Developer ->Code.
Click on Record Macro.
Type a Macro Name: AddNewRow2
Store macro in: This Workbook.
Description: Type a sample description. 
Click OK. Keep going...

Developer ->Code-> Relative References

Comma Training Page 257

Advanced Excel 2010 Page 257 of 298



Exam 77-888: Microsoft Excel Expert 2010
4. Working with Macros and Forms
4.1. Create and manipulate macros.

Record the Steps 
8. Try it: Record the Macro
Select Row 21 (the one with the Sum).
Go to Home->Cells->Insert Sheet Row.

Use the Format Painter: 
Format Same As Above.

Select Cell A22.
AutoFill to A23: Fill Weekdays.

Select Cells B22:E22.
AutoFill the values to B23:E23

Go to Developer ->Code.
Click on Stop Recording.

Keep going, please...

Developer ->Code-> Stop Recording
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4. Working with Macros and Forms
4.1. Create and manipulate macros.

Compare the Code
9. Try it: Review the Code
Go to Developer ->Code-> Macros.
Select a Macro: AddNewRow2.
Click on Edit.

What Do You See? The VBA Editor 
should open in a new window. There 
should be two Subroutines: 
AddNewRows () and AddNewRows2 ().

What Else Do You See? In this code 
ActiveCell is used to create a Relative 
Reference.

Try This As Well: Close the Editor
Go to File->Close and Return to 
Excel.

Very good. 

File->Close and Return to Excel
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4. Working with Macros and Forms
4.1. Create and manipulate macros: Run a Macro from a button

Run the Macro
A good programmer tests every step. This 
is a good place to Run the Macro. 

Before You Begin: The Legs 
spreadsheet is open. Row 22 is 
Selected .

1. Try it: Run the Macro
Go to Developer ->Code->Macros.
Select a Macro: AddNewRow2
Click on Run.

What Do You See? A new Row has been 
added to the spreadsheet. It is formatted 
the same as the row above it and the date 
is the next weekday.

This could be easier. Keep going...

Developer ->Code->Macros-> Run
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4. Working with Macros and Forms
4.1. Create and manipulate macros: Run a Macro from a button

Add the Macro to a Button 
Macros are more User Friendly if they can be 
found on a button. The quickest way to add a 
Macro to a button is with the Backstage 
Options. On the following pages, we will 
create a new Group on the Home Ribbon, 
then add the Macro to the Group.

2. Try it: Go to the Backstage
Go to File ->Options

Keep going...!

File ->Options
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4.1. Create and manipulate macros: Run a Macro from a button

Customize the Ribbon 
What Do You See? The Backstage will 
list the Excel Options. Customize Ribbon 
is the one we are looking for.

3. Try it: Customize the Ribbon
Click on Customize Ribbon.
Choose commands from: Macros.

What Else Do You See? In the example 
on this page there are two Macros:
AddNewRow
AddNewRow2

Keep Looking: On the right side you will 
see a list of the Main Tabs: Home, Insert, 
Page Layout, Formula, Data.

So far, so good. We found the Macros.
Keep going...

File ->Options-> Customize Ribbon
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4. Working with Macros and Forms
4.1. Create and manipulate macros: Run a Macro from a button

Add a New Group 
Custom buttons need to be placed in a 
Custom Group. Here are the steps to 
create a New Group on the Home 
Ribbon.

4. Try it: Create a New Group
Select the Home Ribbon on the right side.
Click on New Group.

Keep going...!

File ->Options-> Customize Ribbon-> New Group
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4. Working with Macros and Forms
4.1. Create and manipulate macros: Run a Macro from a button

Hello, New Group 
5. What Do You See? A New Group 
(Custom) has been placed on the right 
side on the Home Ribbon. By default, the 
New Group has been placed last on the 
list,  under the Editing group. You can use 
the Up and Down arrows to reorganize 
the Main Tab if you wish. 

Keep going...

Memo to Self: Say you changed the 
order of the Groups on the Home Ribbon 
but that made it more difficult to find 
anything. 

You can Reset the Main Tabs and return 
the Home Ribbon to the way it is by 
Default in Excel 2010.

File ->Options-> Customize Ribbon-> New Group
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4. Working with Macros and Forms
4.1. Create and manipulate macros: Run a Macro from a button

Edit the New Group 
New Group (Custom) doesn't really 
mean a whole lot to my users. Let's 
rename this Group. When you Rename a 
Group you can choose a Symbol to help 
Users find a Group as well as a Display 
Name.

6. Try This: Rename the Group
Select New Group (Custom).
Click on Rename.

Whet Do You See? A new window will 
prompt you to select a Symbol.
Type a Display Name: Macros.

Keep going...!

File ->Options-> Customize Ribbon-> New Group
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4. Working with Macros and Forms
4.1. Create and manipulate macros: Run a Macro from a button

Add the Macro to the Group 
Here are the steps to add the Macro to your 
new Macro group on the Home Ribbon.

7. Try This: Add a Macro to a Group
Choose Commands From: Macros.
Click on AddNewRow2

Customize the Ribbon: Main Tabs
Select the new Macro Group.
Click on Add.

Try This, Too: Change the Display Name
Select AddNewRow2.
Click on Rename.

What Do You See? A new window will 
prompt you to select a Symbol.
Type a Display Name: Add New Row.

Click OK. Keep going...!

File ->Options-> Customize Ribbon-> New Group
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4. Working with Macros and Forms
4.1. Create and manipulate macros.

Run the Macro 
What Do You See? There should be a 
new Macro Group on the Home Ribbon. 
The Add New Rows button should be in 
this Group.

So, Try It: Click the Button
Select Row 22.(the one with the SUM)
Go to Home->Macros.
Click on Add New Row.

Did It Work? You should see a new Row 
that includes date, product name, price 
and quantity. The formula in the Revenue 
column should be there as well.

What if it Doesn't Work? You may 
receive a message about Macro security. 

First, save this spreadsheet as a Macro-
enabled workbook. Here are the steps: 
page 269

Second, edit the Macro Security. Here are 
the step: page 270.

Home ->Macros-> Add New Row
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4. Working with Macros and Forms
4.1. Create and manipulate macros.

Add the New Macro to the 
Quick Access Toolbar 
You can add your mighty Macro to the Quick 
Access Toolbar if you wish.

Try it: Add a Macro to the Toolbar
Right-click the Add New Row Macro.
Click on Add to the Quick Access Toolbar.

What Do You See? In the example on this 
page, the Macro is shown as a round, blue 
icon on the Quick Access Toolbar, to the right 
of the Undo and Redo arrows.

Memo to Self: If you choose the other 
option,  Customize the Quick Access 
Toolbar, the steps will be similar to the ones 
we just walked through for the Home Ribbon.

Home ->Macros
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4. Working with Macros and Forms
4.1. Create and manipulate macros: Save as Macro Enabled

Save the Macro 
When you complete the Macro recordings you 
need to save your work as a Macro-Enabled 
file. Macros are code. It is different than the 
default Excel file format. This page shows how 
to save your work. The next couple of pages 
discuss the security issues.

Try it: Save the Macro
Go to File->Save As.

What Do You See? The Save As window will 
prompt you to fill in the following:

Location: Your Documents library

File name: Legs Eggs Pigs with Macros 2010

Save as type: Excel Macro-Enabled Workbook

Click on Save. 

Then Close the Macro-Enabled file Legs Eggs 
Pigs with Macros 2010.

File ->Save As
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4. Working with Macros and Forms
4.1. Create and manipulate macros: Enable Macros in a spreadsheet

Enable Macros in a Workbook 
The Macro Enable workbook icon has a security 
warning: an exclamation point. What happens 
when you open a file that has Macros? 

Try This: Enable Content
Open the file you created in the previous lesson: 
Legs Eggs Pigs with Macros 2010.

What Do You See? There should be a yellow 
security banned at the top of the spreadsheet. By 
default, all Macros are disabled in Excel.

Who Do You Trust? Macros are code: code can 
be programmed to run viruses or malware that can 
compromise your security and your privacy.

Only Enable Content from trusted sources! 

File ->Info
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4. Working with Macros and Forms
4.1. Create and manipulate macros: Enable Macros in a spreadsheet

Security Warnings 
Macros are a security risk. Microsoft Excel 
also displays the security warning in the 
Backstage View of the workbook.

1. Try it: View the Security Information
Open our macro-enabled workbook.
Go to File->Info.
Click on Enable Content.

What Do You See? By default, Active 
Content, including Macros, are disabled 
because of the potential hazards.

You can Enable All Content and make 
this workbook a Trusted Document. 

The Advanced Options allows you to 
enable the macro for this session, only. 

Click on Advanced Options and keep 
going, please...

File->Info->Enable Content-> Advanced Options
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4.1. Create and manipulate macros: Enable Macros in a spreadsheet

Security Alert-Macros 
2. What Do You See? The Macros in the 
workbook are disabled. When you click on 
Advanced Options you will be notified with a 
Security Alert for Macros. 

What Are the Options? One of the Advanced 
Options is to Enable content for this session, 
only. That means the permissions are revoked 
and the Macros are disabled when you close the 
workbook

Click on: Enable content for this session.

Click OK, Keep going.

File->Info->Enable Content-> Advanced Options
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Macro Security 
The example on the previous pages showed 
the options for enabling Macros when you 
open a workbook. 

Macro Security does not have to be "all or 
nothing." Some Macros may be quite useful 
while others are risky. 

Security can be managed in the Backstage
View as well. 

1. Try This: Review the Trust Center
Go to File->Options.
Click on Trust Center.

What Do You See? The Trust Center offers 
several links to teach you how to protect your 
privacy and security.

Keep going...

File ->Options->Trust Center
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Trust Center Settings 
2. Try This: Edit the Trust Center 
Settings for Macros
Go to File ->Options.
Click on Trust Center.
Click on Trust Center Settings.

What Do You See? The Trust Center 
lets you review and edit the settings 
for  accepting macros from Trusted 
Publishers, Trusted Locations, and
Trusted Documents. Microsoft, for 
example, is a Trusted Publisher with 
thousands of macro enabled templates 
on their websites. 

The Macro Settings by default 
Disable all macros with notification. 
You can also choose to trust macros 
that have been digitally signed.

Microsoft does NOT recommend that 
you Enable all macros.

File ->Options->Trust Center-> Trust Center Settings
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Run a Macro On Open 
Microsoft Excel can be programmed to function 
as an application. The spreadsheet can open 
automatically to a form for data entry. Another 
import function is to refresh (import) data from 
an external data connection, such as a 
database or XML.

The example on the following pages will illustrate 
the steps needed to connect to an external 
source, an XML file, and examines the tools for 
working with external data. We will also create a 
macro that updates the connection automatically 
when the workbook is opened.
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1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Import XML data

Before You Begin: Get the Data 
You can connect Excel to many other sources 
including an SQL Server, an SQL Analysis 
Service (such as the traffic data available from 
your commercial website.) 

An XML file is data table of information. It is a 
table so there is a table structure (the fields and 
the relationships) as well as the data. 

Before You Begin: Open Legs Eggs Pigs with 
Macros 2010.xlsm Macro-enabled spreadsheet. 
Download the tblCustomers.xml as well.

The example in the lesson uses a customer table 
that was created from a table in Access.  

1. Try This: Get External Data
Go to a blank sheet and select on Cell A1.
Go to Data ->Get External Data.
Click on From Other Sources.
Click on From XML Data Import.

This will Open or map an XML file into Excel.
Keep going...

Data ->Get External Data->From Other Sources
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1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Import XML data

Select the Data Source 
2. Try This: Select the XML File
The next step in the process is to Browse
for the XML file. This screen shot shows 
the XML file in the Documents folder.

When you are prompted, find and select 
the sample XML file.
Click Open. Keep going...

Thoughts to Consider: Macro security is 
managed by Trust: Trusted Publisher, 
Location, or Trusted Document. Microsoft 
recommends that the XML file should be 
saved in a Trusted Location. 

Data ->Get External Data->From Other Sources
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1.1. Apply workbook settings, properties, and data options: Import XML data

Get External Data 
Where do you want to put the imported data?
When you click on Get External Data you will be 
prompted to choose a worksheet.

3. This This: Choose a Worksheet 
Go to the new, blank worksheet.
Select Cell $A$1.

What Else Do You See? The other options 
include adding the data to an existing worksheet. 
This option would append the data: add to the 
existing rows. You can also put the data in a new 
worksheet.

Click OK. Keep going...

Data ->Get External Data->From Other Sources
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1.1. Apply workbook settings, properties, and data options: Import XML data

Hello, XML Data Table 
4. What Do You See? The XML data will be 
displayed as a Table in Microsoft Excel. 
There are filters in the top row on the fields. 

What Else Do You See? The Table Tools
should be available. On the Design Ribbon 
you should see two useful Groups:

Tools: for PivotTables or Remove 
Duplicates 
External Table Data: to Export or Refresh 
the External Data.

Keep going...

Table Tools ->Design
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1.1. Apply workbook settings, properties, and data options: Import XML data

Show the XML Source 
Let's use the Developer Toolbar to show 
the XML maps in our workbook.

5. Try it: Display the XML Source
Go to Developer ->XML.
Click on Source.

What Do You See? The XML Source will 
be displayed on the right of your XML 
table. This XML Source is similar to the 
Field List in a PivotTable or PivotChart. 

When we imported the XML file, Microsoft 
Excel creates a map of the table structure 
and, by default, named it dataroot_Map.

The XML map includes all of the fields in 
the table. You can drag and drop the 
fields to the spreadsheet as you would to 
create a PivotTable. 

Keep going...

Developer ->XML->Source
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XML Map Properties 
6. Try This: Find the Map Properties
Go to Developer ->XML.
Click on Map Properties.

What Do You See? The XML Map 
Properties include the following:
Name
XML schema validation
Data Source: this option lets you Save the 
data source definition in the workbook.
Data formatting and layout

What Else Do You See? The XML Map 
Properties determines what happens 
when the data is refreshed or imported. 

There are two very different choices:
Overwrite the existing data with new data
Append new data to an existing XML table

The default is to overwrite (replace) the 
data when you refresh or import.

So far so good. Click OK!

Developer ->XML->Map Properties
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4.1. Create and manipulate macros.

Automate the Update 
The next step will create an Auto_Open Macro 
that will Refresh the XML data automatically 
when the workbook is opened.

1. Try This: Create a Refresh Macro
Go to Developer ->Code.
Click on Record Macro.
Enter the following when you are prompted:
Name: Auto_Open
Short Cut Key: Control+Shift+R
Click OK to start the recording.

Try This, Too: Record the Steps
Go to Developer->XML.
Click on Refresh.
Go to Developer->Code.
Click on Stop Recording.

Keep going...!

Developer ->Code->Record Macro

Comma Training Page 282

Advanced Excel 2010 Page 282 of 298



Exam 77-888: Microsoft Excel Expert 2010
4. Working with Macros and Forms
4.1. Create and manipulate macros.

Test the Macro 
In the previous step, we created a new Macro 
and assigned a Shortcut Key. A Shortcut 
Key lets you run the Macro from the 
keyboard. Let's test the new Macro.

Before You Begin: Set up an experiment 
Go to the Customer Table.
Select Rows 4 through Row 771.
Delete the data.

2. Try it: Run a Macro with a Shortcut Key
Type: Control+Shift+R.

What Do You See? By default, the data was 
replaced when it was updated, not added. 
This spreadsheet had 770 customers before 
the data was deleted. There was 770 
customers after the Refresh, not 774.

Save your changes.Keep going...

Memo to Self: Remember, the first Row is 
the Header Row. So, there are 771 Rows in 
the Customer table when you include the 
Header Row.

Developer ->Code-> Macros
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4.1. Create and manipulate macros: Run a Macro when a workbook is opened

Run a Macro On Open 
When Microsoft Excel opens a workbook, it 
looks at the code in a file called Auto_Open. 
There are some limitations to using this 
method. The Auto_Open Macro runs before 
any spreadsheets are opened or created, so 
you might see an error.

Before You Begin: Delete the XML Data
Go to the Customer Table.
Select Rows 4 through Row 771.
Delete the data.
Go to File->Close. 
Save your changes if you are asked.

3. Try This: Test the Auto_Open
Go to File->Open.
Find and select the Legs Eggs Pigs 2010.xlsx
spreadsheet

What Did You See? The data in the 
Customer Table has been refreshed.

File ->Open
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4.1. Create and manipulate macros.

Adding the Export Tools
Consider This: The previous lessons 
focused on importing data into Excel and 
managing it with the Developer Tools.

Exporting XML data requires downloading 
a set of tools: the XML Tools Add-in. The 
Add-in is available from the Microsoft 
Download Center.

When you click Download, you will be 
asked to walk through the installation 
Wizard. You will also be prompted for 
your Administrator password.

Getting the XML Tools Add-in is the first 
step. Keep going...

Developer ->Add-Ins-> Add-Ins
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4.1. Create and manipulate macros.

Add the XML Tools 
2. Try it: Install the Add-Ins
Go to Developer ->Add-Ins-> Add-Ins.
Browse for the XmlTools.xla.
Click OK.

Keep going...!

Developer ->Add-Ins-> Add-Ins
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4.1. Create and manipulate macros.

Hello, XML Tools
Look for the Add-Ins Ribbon to the right of 
the Developer Ribbon. You can use the XML 
Tools to Convert a Range of data into an 
XML List.

3. Try it: Convert a Range to an XML List
Go to the Legs spreadsheet.
Select Cell A1.
Go to Add-Ins-> XML Tools.
Click on Convert a Range to an XML List...
Keep going...

Add-Ins-> XML Tools ->Convert a Range to an XML List...

Comma Training Page 287

Advanced Excel 2010 Page 287 of 298



Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: XML Map Properties

Convert Range to XML List
4. Try it: Select the Range
You will be prompted to select the Range. In 
this example the Range is from A1:D22 (all of 
the date, product and revenue data) but it 
does not include the SUM in Cell D23.

What Else Do You See? You need to 
indicate if the first row is the Header Row. 
Yes, in this example the first row contains the 
column names.

Click OK and keep going...

Add-Ins-> XML Tools ->Convert a Range to an XML List...
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Exam 77-888: Microsoft Excel Expert 2010
4. Working with Macros and Forms
4.1. Create and manipulate macros.

Data Formatting 
5. What Do You See? You may see an error 
message that the data contains formatting 
that is incompatible with the format specified. 

The conversion options are:
Use exiting formatting
Match element data type
Cancel.

Click: Use existing formatting. Keep 
going...

Add-Ins-> XML Tools ->Convert a Range to an XML List...
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Export data as XML

Export the XML 
Now that the Range has been converted to 
XML, you can export the data as an XML file.

6. Try it: Export the XML
Go to Developer ->XML.
Click on Export.

Location: In this example the XML file will be 
saved to the Documents folder.

File Name: tblProducts
Save as type: XML Files

Click Export.

Done and done...sooooo.....

Developer ->XML-> Export
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Exam 77-888: Microsoft Excel Expert 2010
1. Sharing and Maintaining Workbooks
1.1. Apply workbook settings, properties, and data options: Export data as XML

Hello, XML 
So, what does XML look like?

7. Try it: View the XML
Go to the Document folder
Double click tblProducts.

What Do You See? The XML file will 
open in Notepad. The data indicates 
where the rows begin and end with the 
<Row> tags .

Look at the date: that was the data 
that Microsoft Excel warned about 
during the XML conversion.

Alright, that was good. 

Developer ->XML-> Export
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Summary 
This discussion began with a brief introduction to 
Macros. Macros automate many steps into a 
simple program that runs Automatically, say 
when a spreadsheet opens, or On Event, when a 
user clicks on a button.

Our discussion continued with a review of the 
steps to Import and Export data in Extended 
Markup Language (XML.) 

This is the beginning, rather than the end of the 
options for customizing and programming 
Microsoft Excel. And, this completes our study 
for the Microsoft Excel certification exam.

You done good. You can get a whole row of 
cookies if you wish.
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Lesson 7: Working with Macros
Before You Begin: Download the sample spreadsheet: Brown Bag Sales Team.xlsx.

Try This: Do the following steps
1. Open the spreadsheet: Brown Bag Sales Team.xlsx.
2. Use the Excel Backstage Options to show the Developer Ribbon.
3. Record a new Macro:
   Macro Name: GoBlue
   Store macro in: This Worksheet

4. Record the following steps:
   Select Column C (Product)
   Sort: Product
   Select Column D (Sales)
   Apply Conditional Formatting: Light Blue Data Bar

5. Stop Recording. 
6. Test the Macro.
7. Add the GoBlue Macro to the Quick Access Bar.
8. Save this as a Macro-Enabled Worksheet: YOUR NAME My Macro Practice.

Practice Activities
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4. Which of the following is true about Macro Security?
a. Macros are disabled by default because they are a 
security risk
b. Macros can be permanently enabled in a spreadsheet
c. Macros can be temporarily enabled in a spreadsheet for 
only the current session
d. The settings for Macros are found in the Trust Center
Tip: Advanced Excel, page 271, 272, 274 

5. Which of the following can be customized in Excel 2010? 
(Select all correct answers)
a. Ribbons
b. Quick Access Toolbar
c. Document Properties
Tip: Advanced Excel, page 268

1. Which of the following is true about Macros? 
(Select all correct answers)
a. Macros record actions as you complete a task
b. The user must specify the start and stop to a macro 
recording
c. Macros will record mistakes
Tip: Advanced Excel, page 248, 252, 253

2. Which Ribbon has the command for Macros?
a. Home
b. Review
c. Developer
d. Tools
Tip: Advanced Excel, 250

3. Office 2010 allows users to do what with Macros?
(Select all correct answers)
a. Add macros to the Ribbon
b. Create a new group to put a user created macro into
c. Use a custom icon for a user created macro
Tip: Advanced Excel, page 263, 264, 265

Test Yourself
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4. Insert two new Rows above Row 1. Add the following labels:
A1=Start
A2=Increment

Add the following data:
B1=10
B2=2

5. Create a formula in Cell D4: =B1.

6. Create a formula in Cell D5 that adds the first day's quantity to 
the increment in Cell B2. Select Cell D5 and create an Absolute cell 
reference. Autofill the formula to all of the rows that have dates.

7. Rename the spreadsheet to "Budgie." Make a copy of the Budgie 
spreadsheet and name it Expert. 

Change the Product in cell B4 to Expert. Autofill it down to B6 
(Change all of the Budgies to Expert)
Change the Price in cell C4 to $450.00. Autofill it down to C6 
Change the Start in B1=5
Change in Increment in B2=3

Keep going...

Before You Begin: Open a new, blank Spreadsheet in Excel 2010.
Please do the following steps:

1.Create a new spreadsheet for Computers Are Us. 
Add the following labels:
A1=Date
B1=Product
C1=Price
D1=Quantity
E1=Total

Add the following data:
A2=January 5, 2006; 
A3=January 6, 2006
B2=Budgie, 
B3=Budgie,
C2=$350, 
C3=$350
D2=10, 
D3=5
Format Column C for currency

2. Select E2 and calculate the Total of the Price times the Quantity.
3. Select Row 2, copy it, and paste it to Rows 3 through 13.

Advanced Excel Skill Test

Excel 2010 Advanced Skill Test
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12. Create a Best Case and a Worst Case scenario for the car 
payment.
The Best Case changes the Present Value to $20,000 and the numbe
of payments to 48.
The Worst Case changes the Present Value to $16,000 and the 
number of payments to 60.

13. Create a new spreadsheet in this workbook.
   Add the Label: Sales Rep, Total Sold, Sales Goals and Bonus.
   Add the names of three Sales reps
   Add the amount they sold: $1,000, $2,500, and $4,600.

14. Create a Lookup table with two columns: Sales Goals and 
Bonus.    
   The Sales Goals is formatted in currency. 
   The Bonus is formatted in percent. 
   The Sales Goals are $500, $1,000, $2,500, and $4,000. 
   The Bonuses are 5%, 10%, 15% and 20% of the Total Sold.

15. Calculate each Sales Rep's Bonus.

16. Save the file as Your Name Excel Advanced Bonus.
Please submit the Advanced Excel Skill Test to your instructor.

8. Make a copy of the Budgie spreadsheet and name it Summary. 
Delete Columns C and D
Change the Product in Cell B4=All Computers

Create an equation in Cell C4 that adds the Total from the Budgie 
spreadsheet and the Total from the Expert Spreadsheet.

9. Start a new spreadsheet in this workbook. 
Create the following labels:
Enter the Labels
In Cell A1 type: Present Value 
In Cell A2 type: Interest 
In Cell A3 type: Months 
In Cell A4 type: Payment

In Cell B1=$20,000
Cell B2=4%
Cell B3=48

10. Select Cell B4 and use the Function Wizard (fX) to calculate the 
Payment using the PMT function. Remember, the Rate (Cell B2) is 
divided by 12 to get a monthly payment.

11. Select Cell B4 and Goal seek to get the payment under $400 by 
changing the number of payments in Cell B3. Remember the 
payment in the Goal Seek is a NEGATIVE number.

Advanced Excel Skill Test, continued

Excel 2010 Advanced Skill Test
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Microsoft Excel 2010: Index
             Microsoft Office Specialist (MOS): Exam 77-882 and 77-888 for Excel 2010

Save and Send: Change File Type, Pg 214
Save and Send: Create PDF, Pg 215
Save and Send: Save to Web (SkyDrive), Pg 212
Save and Send: Send as XPS, Pg 217
Save and Send: Send Using Email, Pg 208
Save: Save As Template, Pg 203
Sparkline: Change Type, Pg 180
Sparkline: Customize the Axis, Pg 184
Sparkline: Format Styles, Pg 181
Sparkline: Insert a Sparkline, Pg 178
Sparkline: Show or Hide Data Markers, Pg 182
Sparkline: Use Trendlines, Pg 182
Sparklines: Use Sparklines, Pg 178
View: Normal, Pg 148
View: Page Layout, Pg 147
What If Anaysis: Goal Seek, Pg 69
What If Anaysis: Scenario Manager, Pg 71
Worksheet: Tab Color, Pg 187
Worksheets: Copy, Pg 25
Worksheets: Group, Pg 192
Worksheets: Hide Tab, Pg 188
Worksheets: Hide Tab, Pg 188
Worksheets: Insert Sheet, Pg 190
Worksheets: Move or Copy, Pg 186
Worksheets: Move or Copy, Pg 186
Worksheets: Rename Sheet, Pg. 185
Worksheets: Unhide Tab, Pg 189

AutoFill: Copy the Data, Pg 20
AutoFill: Drop Down List Options, Pg 19
AutoFill: Fill a Series, Pg 18
Cell Data: Paste Special, Pg 57
Cell Data: Paste Special, Pg 57
Cell References: Absolute, Pg 37
Format Cells: Issues with Merge, Pg 45
Format Cells: Unmerge Cells, Pg 44
Formula Auditing: Find Invalid Data, Pg 137
Formula Auditing: Find Invalid Formulas, Pg 45
Formula Auditing: Trace Dependents, Pg 41
Formula Auditing: Trace Errors, Pg 45
Formula Auditing: Trace Precedents, Pg 42
Formulas: CONCATENATE (Text), Pg 62
Formulas: Correct Errors in Formulas, Pg 39
Formulas: COUNTIF (Statistical), Pg 101
Formulas: Define a Named Range, Pg 89
   Define a Range with the Formula Bar, Pg 88
   Define a Range with the Mouse, Pg 89
   Define Range with the Keyboard, Pg 224
Formulas: Edit a Named Range, Pg 95
Formulas: Edit Defined Conditions, Pg 100
Formulas: Automatic Calculations, Pg 221
Formulas: Error Checking, Pg 45
Formulas: Evaluating Formulas, Pg 220
Formulas: Iterative Calculations, Pg 222
Formulas: MONTH (Date), Pg 69

Formulas: Order of evaluation, Pg 218
Formulas: PMT (Financial), Pg 77
Formulas: Precedence (Parenthesis), Pg 219
Formulas: Rename a Named Range, Pg 89
Formulas: SUMIFS, Pg 99
Formulas: Time (Numbers), Pg 74
Formulas: Series of Conditional Logic Pg 102
Formulas: Use Arrays (Hlookup)Pg 125
Formulas: Using Lookup Functions, Pg 115
Header/Footer: Scale and Align, Pg 161
Headers/Footers: Different First Page, Pg 161
Headers/Footers: Odd or Even Pages, Pg 164
Hyperlink: Create a Hyperlink, Pg 198
Hyperlink: Modify Hyperlink in a Cell, Pg 193
Hyperlink: Modify Hyperlink Options, Pg 195
Hyperlink: Remove a Hyperlink, Pg 199
Navigate with Named Ranges, Pg 88
Page Layout: Page Scaling, Pg 166
Page Layout: Sheet Options, Pg 165
Page Setup: Headers and Footers, Pg 159
Page Setup: Margins, Pg 150
Page Setup: Orientation, Pg 149
Page Setup: Print Columns that Repeat, Pg 156
Page Setup: Print Rows that Repeat, Pg 156
Page Setup: Print Titles, Pg 156
Print: Print Entire Workbook, Pg 167
Print: Print Preview, Pg 157
Print: Print Selected Worksheets, Pg 168

Index
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Advanced Microsoft Excel 2010: Glossary
             Microsoft Office Specialist (MOS): Exam 77-882 and 77-888 Excel 2010

Quick Access Toolbar—customizable toolbar at the 
top of Microsoft Word pg.220

Range— a group of cells pg.21

Slicers—filters for Pivot Table data pg.147

Styles— collection of preset formatting to be applied 
to text or objects pg.21

Subtotal—a total for a given section or category that 
is later included in a Grand Total pg.56

Table properties—includes name, range, and other 
information about the table pg.41

Title bar—the bar at the top of a program that 
includes the program name and, if applicable, the 
current file name pg.13

Track Changes— when enabled, marks all additions, 
deletions, and formatting made to the text.  Also 
allows reversion to original text pg.211

Trust Center—contains privacy and security settings 
for that Microsoft Office program pg.274

What If Scenario—a prediction tool that uses the data 
in the spreadsheet without making permanent 
changes to the original data pg.71

AutoFill— function that fills data, usually in a 
series such as predefined increments or months 
pg.169

Banded rows— alternating color or shading of 
rows to make reading easier pg.22

Combo box—a drop-down list of options created 
using the form controls pg.187

Comment—little notes added to a spreadsheet in 
Excel that are indicated by a mark in the corner of 
the cell and out of sight until selected pg.215

Conditional formatting—the color or icon 
displayed depends on whether the cell values 
match certain criteria pg.30

Data validation—tool that compares the user 
input for match with predefined settings and 
supplies alerts for incorrect input.  Also can be 
used to create drop-down lists pg.171

Digital signature—digital coding that is intended 
to validate the integrity of a filea single command 
that represents a set or sequence of commandsa 
single command that represents a set or sequence 
of commands pg.233

Document Inspector—allows user to review the 
document for personal or sensitive information 
before sharingpg.226

Drop down list—a list of options that opens when 
clicked, usually opening down.  In Excel, it is 
created using data validation pg.175

Goal Seek— a what-if analysis tool that allows a 
user to find the input value necessary to achieve a 
desired result pg.68

Grand total—a total for all subgroups and 
subtotals pg.106

Headers—material separate from the document 
contents that appears at the top of the page pg.14

Macros— a single command that represents a set 
or sequence of commands pg.247

Object— any item other than text used in a file, 
such as a shape, picture, Clip Art, etc pg.139

Pivot Chart—chart created from the reconfigured 
data summarized in a Pivot Chartpg.123

Pivot Table—a tool that allows for summary and 
analysis of large data sets by reconfiguring (ie, 
pivoting) the data, often used for summary reports 
pg.87

Advanced Microsoft Excel 2010 Glossary
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